EPegtopAsmInvalidOperand Class

Links
PegtopAssemblers, Legend, Members, Methods
PegtopMath
Contents | Index
Next
EPegtopAsmInvalidOperand Class
PegtopAssemblers | Legend | Members | Methods
Show All
Class Hierarchy

EPegtopAsmInvalidOperand = class(EPegtopCompiler);
File

PegtopAssemblers

Description

EPegtopAsmInvalidOperand is raised when an asm operator expects another operand then specified (for example when a 16 bit register is used when a 32 bit register is expected).

Methods
Method | Description
CreateProp | EPegtopAsmInvalidArg
Legend
Method
Links
PegtopAssemblers, Legend, Members, Methods
Copyright (c) 2005. All rights reserved.
Contents | Index
What do you think about this topic? Send feedback!


EPegtopAsmInvalidOperand.CreateProp Constructor

Links
EPegtopAsmInvalidOperand Class
PegtopMath
Contents | Index
Up
EPegtopAsmInvalidOperand.CreateProp Constructor
EPegtopAsmInvalidOperand Class
Show All
constructor CreateProp(const OpCode: String; const Found: String; const Expected: String);
Description

EPegtopAsmInvalidArg

Class

EPegtopAsmInvalidOperand Class

Links
EPegtopAsmInvalidOperand Class
Copyright (c) 2005. All rights reserved.


EPegtopCompiler Class

Links
PegtopCompilers
PegtopMath
Contents | Index
Previous | Next
EPegtopCompiler Class
PegtopCompilers
Show All
Class Hierarchy

EPegtopCompiler = class(Exception);
File

PegtopCompilers

Description

EPegtopCompiler is the base class for all exceptions raised by TPegtopCompilerData, TPegtopCompilerCode, TPegtopAsmCode and other classes involved compiling to machine code.

Links
PegtopCompilers
Copyright (c) 2005. All rights reserved.


EPegtopFormula Class

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
EPegtopFormula Class
PegtopFormulas
Show All
Class Hierarchy

EPegtopFormula = class(Exception);
File

PegtopFormulas

Description

EPegtopFormula is the base class for all exceptions raised by TPegtopFormula and other classes used by TPegtopFormula (except of the compiler, which raises EPegtopCompiler, what should rarely happen).

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


EPegtopFormulaArgument Class

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
EPegtopFormulaArgument Class
PegtopFormulas
Show All
Class Hierarchy

EPegtopFormulaArgument = class(EPegtopFormula);
File

PegtopFormulas

Description

EPegtopFormulaArgument indicates that wrong arguments were given to TPegtopFormula (for example too many arguments or arguments with wrong names).

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


EPegtopFormulaBadSpecifier Class

Links
PegtopFormulas, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous | Next
EPegtopFormulaBadSpecifier Class
PegtopFormulas | Legend | Members | Methods | Properties
Show All
Class Hierarchy

EPegtopFormulaBadSpecifier = class(EPegtopFormulaParse);
File

PegtopFormulas

Description

EPegtopFormulaBadSpecifier indicates a bad specifier while parsing an expression.

Methods
Method | Description
CreateProp | EPegtopFormulaBadSpecifier
EPegtopFormulaParse Class
Method | Description
CreateProp | EPegtopFormulaParse
Properties
Property | Description
Specifier | This is Specifier, a member of class EPegtopFormulaBadSpecifier.
EPegtopFormulaParse Class
Property | Description
Expected | This is Expected, a member of class EPegtopFormulaParse.
Expression | This is Expression, a member of class EPegtopFormulaParse.
Invalid | This is Invalid, a member of class EPegtopFormulaParse.
Position | This is Position, a member of class EPegtopFormulaParse.
Legend
Property
read only
Method
Links
PegtopFormulas, Legend, Members, Methods, Properties


EPegtopFormulaBadSpecifier.Specifier Property

Links
EPegtopFormulaBadSpecifier Class
PegtopMath
Contents | Index
Up | Next
EPegtopFormulaBadSpecifier.Specifier Property
EPegtopFormulaBadSpecifier Class
Show All
property Specifier: String;
Description

This is Specifier, a member of class EPegtopFormulaBadSpecifier.

Class

EPegtopFormulaBadSpecifier Class

Links
EPegtopFormulaBadSpecifier Class
Copyright (c) 2005. All rights reserved.


EPegtopFormulaBadSpecifier.CreateProp Constructor

Links
EPegtopFormulaBadSpecifier Class
PegtopMath
Contents | Index
Up | Previous
EPegtopFormulaBadSpecifier.CreateProp Constructor
EPegtopFormulaBadSpecifier Class
Show All
constructor CreateProp(const ASpecifier: String);
Description

EPegtopFormulaBadSpecifier

Class

EPegtopFormulaBadSpecifier Class

Links
EPegtopFormulaBadSpecifier Class
Copyright (c) 2005. All rights reserved.


EPegtopFormulaInvalid Class

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
EPegtopFormulaInvalid Class
PegtopFormulas
Show All
Class Hierarchy

EPegtopFormulaInvalid = class(EPegtopFormula);
File

PegtopFormulas

Description

EPegtopFormulaInvalid is raised for invalid expressions.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


EPegtopFormulaParameter Class

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
EPegtopFormulaParameter Class
PegtopFormulas
Show All
Class Hierarchy

EPegtopFormulaParameter = class(EPegtopFormula);
File

PegtopFormulas

Description

EPegtopFormulaParse indicates that something is wrong with the parameters (for example two identical names are used).

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


EPegtopFormulaParse Class

Links
PegtopFormulas, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous | Next
EPegtopFormulaParse Class
PegtopFormulas | Legend | Members | Methods | Properties
Show All
Class Hierarchy

EPegtopFormulaParse = class(EPegtopFormula);
File

PegtopFormulas

Description

EPegtopFormulaParse indicates an exception while parsing an expression.

Methods
Method | Description
CreateProp | EPegtopFormulaParse
Properties
Property | Description
Expected | This is Expected, a member of class EPegtopFormulaParse.
Expression | This is Expression, a member of class EPegtopFormulaParse.
Invalid | This is Invalid, a member of class EPegtopFormulaParse.
Position | This is Position, a member of class EPegtopFormulaParse.
Legend
Property
read only
Method
Links
PegtopFormulas, Legend, Members, Methods, Properties


EPegtopFormulaParse.Expected Property

Links
EPegtopFormulaParse Class
PegtopMath
Contents | Index
Up | Next
EPegtopFormulaParse.Expected Property
EPegtopFormulaParse Class
Show All
property Expected: String;
Description

This is Expected, a member of class EPegtopFormulaParse.

Class

EPegtopFormulaParse Class

Links
EPegtopFormulaParse Class
Copyright (c) 2005. All rights reserved.


EPegtopFormulaParse.Expression Property

Links
EPegtopFormulaParse Class
PegtopMath
Contents | Index
Up | Previous | Next
EPegtopFormulaParse.Expression Property
EPegtopFormulaParse Class
Show All
property Expression: String;
Description

This is Expression, a member of class EPegtopFormulaParse.

Class

EPegtopFormulaParse Class

Links
EPegtopFormulaParse Class
Copyright (c) 2005. All rights reserved.


EPegtopFormulaParse.Invalid Property

Links
EPegtopFormulaParse Class
PegtopMath
Contents | Index
Up | Previous | Next
EPegtopFormulaParse.Invalid Property
EPegtopFormulaParse Class
Show All
property Invalid: String;
Description

This is Invalid, a member of class EPegtopFormulaParse.

Class

EPegtopFormulaParse Class

Links
EPegtopFormulaParse Class
Copyright (c) 2005. All rights reserved.


EPegtopFormulaParse.Position Property

Links
EPegtopFormulaParse Class
PegtopMath
Contents | Index
Up | Previous | Next
EPegtopFormulaParse.Position Property
EPegtopFormulaParse Class
Show All
property Position: Integer;
Description

This is Position, a member of class EPegtopFormulaParse.

Class

EPegtopFormulaParse Class

Links
EPegtopFormulaParse Class
Copyright (c) 2005. All rights reserved.


EPegtopFormulaParse.CreateProp Constructor

Links
EPegtopFormulaParse Class
PegtopMath
Contents | Index
Up | Previous
EPegtopFormulaParse.CreateProp Constructor
EPegtopFormulaParse Class
Show All
constructor CreateProp(const AExpression: String; const APosition: Integer; const AExpected: String);
Description

EPegtopFormulaParse

Class

EPegtopFormulaParse Class

Links
EPegtopFormulaParse Class
Copyright (c) 2005. All rights reserved.


TPegtopAsmCode Class

Links
PegtopAssemblers, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous | Next
TPegtopAsmCode Class
PegtopAssemblers | Legend | Members | Methods | Properties
Show All
Class Hierarchy

TPegtopAsmCode = class(TPegtopCompilerCode);
File

PegtopAssemblers

Description

TPegtopAsmCode is based on TPegtopCompilerCode and defines all (for TPegtopFormulaCompiler) important asm instructions.

Methods
TPegtopCompilerCode Class
Method | Description
AddAddr | Add virtual address to code block.
AddCode | Add code byte to code block.
AddJump | Add jump to code block. The target label can either be added before or after this operation.
AddLabel | Add label to code block.
AddLine | Add line of text to code block as documentation of the machine code (usually this is asm code).
AddrToHex | Transform virtual address to hex string.
CleanUp | Clean up name spaces after finishing code creation. This method makes sure all name spaces are closed, and should be called before destroying TPegtopCompilerCode. It is not part of the destructor, because a destructor should never raise exceptions.
Clear | Clear code block.
CloseNameSpace | Close name space opened with OpenNameSpace.
Create | Create new TPegtopCompilerCode object , reinitializing data type alignment (see TPegtopCompilerData constructor).
DecIndent | Decrease indent width used when adding text lines.
Destroy | Destroy TPegtopCompilerCode object. You should call CleanUp (see there) before destroying a TPegtopCompilerCode object.
IncIndent | Increase indent width used when adding text lines.
OpenNameSpace | Open new name space. Name spaces can be nested.
TPegtopCompilerData Class
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.
Properties
TPegtopCompilerCode Class
Property | Description
Data | data block belonging to this code block
Lines | text lines of code block (for documentation, usually contains the asm instructions to generate the machine code)
TPegtopCompilerData Class
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)
Legend
Property
read only
Method
protected
virtual
Links
PegtopAssemblers, Legend, Members, Methods, Properties


TPegtopCompilerCode Class

Links
PegtopCompilers, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous | Next
TPegtopCompilerCode Class
PegtopCompilers | Legend | Members | Methods | Properties
Show All
Class Hierarchy

TPegtopCompilerCode = class(TPegtopCompilerData);
File

PegtopCompilers

Description

TPegtopCompilerCode is a special TPegtopCompilerData data block used to store machine code. It features name spaces, which can be used to define labels and jumps only valid within a name space (another name space can use labels with the same names without conflicts). TPegtopCompilerCode also holds a string list with the asm instructions used to generate the machine code (the creator of the machine code is responsible for adding this information correctly).

Methods
Method | Description
AddAddr | Add virtual address to code block.
AddCode | Add code byte to code block.
AddJump | Add jump to code block. The target label can either be added before or after this operation.
AddLabel | Add label to code block.
AddLine | Add line of text to code block as documentation of the machine code (usually this is asm code).
AddrToHex | Transform virtual address to hex string.
CleanUp | Clean up name spaces after finishing code creation. This method makes sure all name spaces are closed, and should be called before destroying TPegtopCompilerCode. It is not part of the destructor, because a destructor should never raise exceptions.
Clear | Clear code block.
CloseNameSpace | Close name space opened with OpenNameSpace.
Create | Create new TPegtopCompilerCode object , reinitializing data type alignment (see TPegtopCompilerData constructor).
DecIndent | Decrease indent width used when adding text lines.
Destroy | Destroy TPegtopCompilerCode object. You should call CleanUp (see there) before destroying a TPegtopCompilerCode object.
IncIndent | Increase indent width used when adding text lines.
OpenNameSpace | Open new name space. Name spaces can be nested.
TPegtopCompilerData Class
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.
Properties
Property | Description
Data | data block belonging to this code block
Lines | text lines of code block (for documentation, usually contains the asm instructions to generate the machine code)
TPegtopCompilerData Class
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)
Legend
Property
read only
Method
protected
virtual
Links
PegtopCompilers, Legend, Members, Methods, Properties


TPegtopCompilerCode.Data Property

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Next
TPegtopCompilerCode.Data Property
TPegtopCompilerCode Class
Show All
property Data: TPegtopCompilerData;
Description

data block belonging to this code block

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.Lines Property

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.Lines Property
TPegtopCompilerCode Class
Show All
property Lines: TStrings;
Description

text lines of code block (for documentation, usually contains the asm instructions to generate the machine code)

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.AddAddr Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.AddAddr Method
TPegtopCompilerCode Class
Show All
procedure AddAddr(V: LongWord);
Description

Add virtual address to code block.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.AddCode Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.AddCode Method
TPegtopCompilerCode Class
Show All
procedure AddCode(V: Byte);
Description

Add code byte to code block.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.AddJump Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.AddJump Method
TPegtopCompilerCode Class
Show All
procedure AddJump(Lab: String);
Description

Add jump to code block. The target label can either be added before or after this operation.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.AddLabel Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.AddLabel Method
TPegtopCompilerCode Class
Show All
procedure AddLabel(Lab: String);
Description

Add label to code block.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.AddLine Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.AddLine Method
TPegtopCompilerCode Class
Show All
procedure AddLine(S: String);
Description

Add line of text to code block as documentation of the machine code (usually this is asm code).

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.AddrToHex Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.AddrToHex Method
TPegtopCompilerCode Class
Show All
function AddrToHex(A: TPegtopVirtualAddr): String;
Description

Transform virtual address to hex string.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.CleanUp Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.CleanUp Method
TPegtopCompilerCode Class
Show All
procedure CleanUp;
Description

Clean up name spaces after finishing code creation. This method makes sure all name spaces are closed, and should be called before destroying TPegtopCompilerCode. It is not part of the destructor, because a destructor should never raise exceptions.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.Clear Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.Clear Method
TPegtopCompilerCode Class
Show All
procedure Clear; override;
Description

Clear code block.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.CloseNameSpace Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.CloseNameSpace Method
TPegtopCompilerCode Class
Show All
procedure CloseNameSpace;
Description

Close name space opened with OpenNameSpace.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.Create Constructor

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.Create Constructor
TPegtopCompilerCode Class
Show All
constructor Create(AData: TPegtopCompilerData);
Description

Create new TPegtopCompilerCode object , reinitializing data type alignment (see TPegtopCompilerData constructor).

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.DecIndent Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.DecIndent Method
TPegtopCompilerCode Class
Show All
procedure DecIndent;
Description

Decrease indent width used when adding text lines.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.Destroy Destructor

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.Destroy Destructor
TPegtopCompilerCode Class
Show All
destructor Destroy; override;
Description

Destroy TPegtopCompilerCode object. You should call CleanUp (see there) before destroying a TPegtopCompilerCode object.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.IncIndent Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerCode.IncIndent Method
TPegtopCompilerCode Class
Show All
procedure IncIndent;
Description

Increase indent width used when adding text lines.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerCode.OpenNameSpace Method

Links
TPegtopCompilerCode Class
PegtopMath
Contents | Index
Up | Previous
TPegtopCompilerCode.OpenNameSpace Method
TPegtopCompilerCode Class
Show All
procedure OpenNameSpace(Name: String);
Description

Open new name space. Name spaces can be nested.

Class

TPegtopCompilerCode Class

Links
TPegtopCompilerCode Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData Class

Links
PegtopCompilers, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous | Next
TPegtopCompilerData Class
PegtopCompilers | Legend | Members | Methods | Properties
Show All
Class Hierarchy

TPegtopCompilerData = class;
File

PegtopCompilers

Description

TPegtopCompilerData defines a block of data, either for variables or for code (see TPegtopCompilerCode).

Methods
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.
Properties
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)
Legend
Property
read only
Method
virtual
Links
PegtopCompilers, Legend, Members, Methods, Properties


TPegtopCompilerData.Ptr Property

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Next
TPegtopCompilerData.Ptr Property
TPegtopCompilerData Class
Show All
property Ptr [A: TPegtopVirtualAddr]: Pointer;
Description

pointer to virtual address within data block

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData.Size Property

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerData.Size Property
TPegtopCompilerData Class
Show All
property Size: Integer;
Description

size of data block (not its capacity)

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData.AddByte Method

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerData.AddByte Method
TPegtopCompilerData Class
Show All
function AddByte(V: Byte): TPegtopVirtualAddr;
Description

Add a byte value to the data block.

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData.AddDouble Method

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerData.AddDouble Method
TPegtopCompilerData Class
Show All
function AddDouble(V: Double): TPegtopVirtualAddr;
Description

Add a double precision floating point value to the data block.

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData.AddInt64 Method

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerData.AddInt64 Method
TPegtopCompilerData Class
Show All
function AddInt64(V: Int64): TPegtopVirtualAddr;
Description

Add a signed 64 bit integer value to the data block.

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData.AddLongint Method

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerData.AddLongint Method
TPegtopCompilerData Class
Show All
function AddLongint(V: Longint): TPegtopVirtualAddr;
Description

Add a signed 32 bit integer value to the data block.

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData.AddSmallint Method

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerData.AddSmallint Method
TPegtopCompilerData Class
Show All
function AddSmallint(V: Smallint): TPegtopVirtualAddr;
Description

Add a signed 16 bit integer value to the data block.

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData.AddWord Method

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerData.AddWord Method
TPegtopCompilerData Class
Show All
function AddWord(V: Word): TPegtopVirtualAddr;
Description

Add an unsigned 16 bit integer value to the data block.

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData.Clear Method

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerData.Clear Method
TPegtopCompilerData Class
Show All
procedure Clear; virtual;
Description

Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData.Create Constructor

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerData.Create Constructor
TPegtopCompilerData Class
Show All
constructor Create;
Description

Create new TPegtopCompilerData object, initializing data type alignment.

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData.IncSize Method

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopCompilerData.IncSize Method
TPegtopCompilerData Class
Show All
function IncSize(Bytes: Integer; Align: Integer): TPegtopVirtualAddr;
Description

Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopCompilerData.SetByte Method

Links
TPegtopCompilerData Class
PegtopMath
Contents | Index
Up | Previous
TPegtopCompilerData.SetByte Method
TPegtopCompilerData Class
Show All
procedure SetByte(A: TPegtopVirtualAddr; V: Byte);
Description

Set a specific byte within the data block to another value.

Class

TPegtopCompilerData Class

Links
TPegtopCompilerData Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula Class

Links
PegtopFormulas, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous | Next
TPegtopFormula Class
PegtopFormulas | Legend | Members | Methods | Properties
Show All
Class Hierarchy

TPegtopFormula = class(TComponent);
File

PegtopFormulas

Description

TPegtopFormula is a fast expression evaluator component.

Methods
Method | Description
Compile | Compiles the current expression to machine code (only if it wasn't compiled yet).
Create | Creates a new TPegtopFormula component.
Destroy | Destroys a TPegtopFormula component.
Eval | Evaluates an expression with arguments set with SetArg. The expression is compiled automatically if it wasn't compiled yet.
GetArg | Get the current argument value given by its parameter index. This method usually is faster than the overloaded GetArg method accepting a parameter name.
Recompile | Forces the expression to be recompiled, even if it was compiled before.
SetArg | Set the an argument value given by its parameter index. This method usually is faster than the overloaded SetArg method accepting a parameter name.
Properties
Property | Description
CodeLines | This is CodeLines, a member of class TPegtopFormula.
CodeSize | This is CodeSize, a member of class TPegtopFormula.
Expression | mathematical formula expression as a string (is compiled by calling Compile or automatically when needed)
MathErrors | list of 80x87 FPU errors, which result in an exception (when set to False no exception is raised, instead the result can be infinite or not a number)
MathInfinity | type of infinity used (depending on the FPU this is a reserved flag)
MathPrecision | precision used by the 80x87 FPU internally (see TPegtopMathPrecision)
Options | options used by TPegtopFormula
Parameters | parameter names
Valid | This is Valid, a member of class TPegtopFormula.
Legend
Property
read only
Method
virtual
Links
PegtopFormulas, Legend, Members, Methods, Properties


TPegtopFormula.CodeLines Property

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Next
TPegtopFormula.CodeLines Property
TPegtopFormula Class
Show All
property CodeLines: TStrings;
Description

This is CodeLines, a member of class TPegtopFormula.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.CodeSize Property

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormula.CodeSize Property
TPegtopFormula Class
Show All
property CodeSize: Integer;
Description

This is CodeSize, a member of class TPegtopFormula.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.Expression Property

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormula.Expression Property
TPegtopFormula Class
Show All
property Expression: String;
Description

mathematical formula expression as a string (is compiled by calling Compile or automatically when needed)

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.MathErrors Property

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormula.MathErrors Property
TPegtopFormula Class
Show All
property MathErrors: TPegtopMathErrors;
Description

list of 80x87 FPU errors, which result in an exception (when set to False no exception is raised, instead the result can be infinite or not a number)

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.MathInfinity Property

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormula.MathInfinity Property
TPegtopFormula Class
Show All
property MathInfinity: TPegtopMathInfinity;
Description

type of infinity used (depending on the FPU this is a reserved flag)

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.MathPrecision Property

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormula.MathPrecision Property
TPegtopFormula Class
Show All
property MathPrecision: TPegtopMathPrecision;
Description

precision used by the 80x87 FPU internally (see TPegtopMathPrecision)

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.Options Property

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormula.Options Property
TPegtopFormula Class
Show All
property Options: TPegtopFormulaOptions;
Description

options used by TPegtopFormula

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.Parameters Property

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormula.Parameters Property
TPegtopFormula Class
Show All
property Parameters: TStrings;
Description

parameter names

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.Valid Property

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormula.Valid Property
TPegtopFormula Class
Show All
property Valid: Boolean;
Description

This is Valid, a member of class TPegtopFormula.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.Compile Method

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormula.Compile Method
TPegtopFormula Class
Show All
procedure Compile;
Description

Compiles the current expression to machine code (only if it wasn't compiled yet).

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.Create Constructor

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormula.Create Constructor
TPegtopFormula Class
Show All
constructor Create(AOwner: TComponent); override;
Description

Creates a new TPegtopFormula component.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.Destroy Destructor

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormula.Destroy Destructor
TPegtopFormula Class
Show All
destructor Destroy; override;
Description

Destroys a TPegtopFormula component.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.Eval Method ()

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Next
TPegtopFormula.Eval Method ()
TPegtopFormula Class
Show All
function Eval: Double; overload;
Description

Evaluates an expression with arguments set with SetArg. The expression is compiled automatically if it wasn't compiled yet.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.Eval Method (array of Double)

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous
TPegtopFormula.Eval Method (array of Double)
TPegtopFormula Class
Show All
function Eval(const Args: array of Double): Double; overload;
Description

Evaluates an expression with arguments given as an array. The number of arguments must not exceed the number of parameters specified for the formula. If less arguments are passed, undefined arguments equal the ones of the last call or the ones set with SetArg. The expression is compiled automatically if it wasn't compiled yet.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.GetArg Method (Integer)

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Next
TPegtopFormula.GetArg Method (Integer)
TPegtopFormula Class
Show All
function GetArg(Index: Integer): Double; overload;
Description

Get the current argument value given by its parameter index. This method usually is faster than the overloaded GetArg method accepting a parameter name.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.GetArg Method (String)

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous
TPegtopFormula.GetArg Method (String)
TPegtopFormula Class
Show All
function GetArg(Name: String): Double; overload;
Description

Get the current argument value given by its parameter name. This method usually is slower than the overloaded GetArg method accepting a parameter index.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.Recompile Method

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous
TPegtopFormula.Recompile Method
TPegtopFormula Class
Show All
procedure Recompile;
Description

Forces the expression to be recompiled, even if it was compiled before.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.SetArg Method (Integer, Double)

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Next
TPegtopFormula.SetArg Method (Integer, Double)
TPegtopFormula Class
Show All
procedure SetArg(Index: Integer; Value: Double); overload;
Description

Set the an argument value given by its parameter index. This method usually is faster than the overloaded SetArg method accepting a parameter name.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormula.SetArg Method (String, Double)

Links
TPegtopFormula Class
PegtopMath
Contents | Index
Up | Previous
TPegtopFormula.SetArg Method (String, Double)
TPegtopFormula Class
Show All
procedure SetArg(Name: String; Value: Double); overload;
Description

Set the an argument value given by its parameter name. This method usually is slower than the overloaded SetArg method accepting a parameter index.

Class

TPegtopFormula Class

Links
TPegtopFormula Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaCompiler Class

Links
PegtopFormulas, Legend, Members, Methods
PegtopMath
Contents | Index
Previous | Next
TPegtopFormulaCompiler Class
PegtopFormulas | Legend | Members | Methods
Show All
Class Hierarchy

TPegtopFormulaCompiler = class;
File

PegtopFormulas

Description

TPegtopFormulaCompiler is used to compile an expression to machine code.

Methods
Method | Description
CleanUp | This is CleanUp, a member of class TPegtopFormulaCompiler.
Create | TPegtopFormulaCompiler
Destroy | This is Destroy, a member of class TPegtopFormulaCompiler.
Parse | This is Parse, a member of class TPegtopFormulaCompiler.
Legend
Method
virtual
Links
PegtopFormulas, Legend, Members, Methods
Copyright (c) 2005. All rights reserved.


TPegtopFormulaCompiler.CleanUp Method

Links
TPegtopFormulaCompiler Class
PegtopMath
Contents | Index
Up | Next
TPegtopFormulaCompiler.CleanUp Method
TPegtopFormulaCompiler Class
Show All
procedure CleanUp;
Description

This is CleanUp, a member of class TPegtopFormulaCompiler.

Class

TPegtopFormulaCompiler Class

Links
TPegtopFormulaCompiler Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaCompiler.Create Constructor

Links
TPegtopFormulaCompiler Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormulaCompiler.Create Constructor
TPegtopFormulaCompiler Class
Show All
constructor Create(ACode: TPegtopMacroAsmCode; Parameters: TStrings);
Description

TPegtopFormulaCompiler

Class

TPegtopFormulaCompiler Class

Links
TPegtopFormulaCompiler Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaCompiler.Destroy Destructor

Links
TPegtopFormulaCompiler Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormulaCompiler.Destroy Destructor
TPegtopFormulaCompiler Class
Show All
destructor Destroy; override;
Description

This is Destroy, a member of class TPegtopFormulaCompiler.

Class

TPegtopFormulaCompiler Class

Links
TPegtopFormulaCompiler Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaCompiler.Parse Method

Links
TPegtopFormulaCompiler Class
PegtopMath
Contents | Index
Up | Previous
TPegtopFormulaCompiler.Parse Method
TPegtopFormulaCompiler Class
Show All
procedure Parse(Expression: String; AutoCloseBrackets: Boolean = True; NationalDecimalSeparator: Boolean = False);
Description

This is Parse, a member of class TPegtopFormulaCompiler.

Class

TPegtopFormulaCompiler Class

Links
TPegtopFormulaCompiler Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaElement Class

Links
PegtopFormulas, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous | Next
TPegtopFormulaElement Class
PegtopFormulas | Legend | Members | Methods | Properties
Show All
Class Hierarchy

TPegtopFormulaElement = class;
File

PegtopFormulas

Description

TPegtopFormulaElement is an element of an expression, like a TPegtopFormulaVariable or a TPegtopFormulaFunction.

Methods
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaElement.
GetPrio | This is GetPrio, a member of class TPegtopFormulaElement.
Properties
Property | Description
Level | This is Level, a member of class TPegtopFormulaElement.
Negative | This is Negative, a member of class TPegtopFormulaElement.
Prev | This is Prev, a member of class TPegtopFormulaElement.
Prio | This is Prio, a member of class TPegtopFormulaElement.
Legend
Property
read only
Method
abstract
protected
Links
PegtopFormulas, Legend, Members, Methods, Properties


TPegtopFormulaElement.Level Property

Links
TPegtopFormulaElement Class
PegtopMath
Contents | Index
Up | Next
TPegtopFormulaElement.Level Property
TPegtopFormulaElement Class
Show All
property Level: Integer;
Description

This is Level, a member of class TPegtopFormulaElement.

Class

TPegtopFormulaElement Class

Links
TPegtopFormulaElement Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaElement.Negative Property

Links
TPegtopFormulaElement Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormulaElement.Negative Property
TPegtopFormulaElement Class
Show All
property Negative: Boolean;
Description

This is Negative, a member of class TPegtopFormulaElement.

Class

TPegtopFormulaElement Class

Links
TPegtopFormulaElement Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaElement.Prev Property

Links
TPegtopFormulaElement Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormulaElement.Prev Property
TPegtopFormulaElement Class
Show All
property Prev: TPegtopFormulaElement;
Description

This is Prev, a member of class TPegtopFormulaElement.

Class

TPegtopFormulaElement Class

Links
TPegtopFormulaElement Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaElement.Prio Property

Links
TPegtopFormulaElement Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormulaElement.Prio Property
TPegtopFormulaElement Class
Show All
property Prio: Integer;
Description

This is Prio, a member of class TPegtopFormulaElement.

Class

TPegtopFormulaElement Class

Links
TPegtopFormulaElement Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaElement.Compile Method

Links
TPegtopFormulaElement Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormulaElement.Compile Method
TPegtopFormulaElement Class
Show All
procedure Compile(Code: TPegtopMacroAsmCode); virtual; abstract;
Description

This is Compile, a member of class TPegtopFormulaElement.

Class

TPegtopFormulaElement Class

Links
TPegtopFormulaElement Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaElement.GetPrio Method

Links
TPegtopFormulaElement Class
PegtopMath
Contents | Index
Up | Previous
TPegtopFormulaElement.GetPrio Method
TPegtopFormulaElement Class
Show All
function GetPrio: Integer; virtual; abstract;
Description

This is GetPrio, a member of class TPegtopFormulaElement.

Class

TPegtopFormulaElement Class

Links
TPegtopFormulaElement Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaFunction Class

Links
PegtopFormulas, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous | Next
TPegtopFormulaFunction Class
PegtopFormulas | Legend | Members | Methods | Properties
Show All
Class Hierarchy

TPegtopFormulaFunction = class(TPegtopFormulaElement);
File

PegtopFormulas

Description

TPegtopFormulaFunction is a function of an expression.

Methods
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaFunction.
Create | TPegtopFormulaFunction
GetPrio | This is GetPrio, a member of class TPegtopFormulaFunction.
TPegtopFormulaElement Class
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaElement.
GetPrio | This is GetPrio, a member of class TPegtopFormulaElement.
Properties
TPegtopFormulaElement Class
Property | Description
Level | This is Level, a member of class TPegtopFormulaElement.
Negative | This is Negative, a member of class TPegtopFormulaElement.
Prev | This is Prev, a member of class TPegtopFormulaElement.
Prio | This is Prio, a member of class TPegtopFormulaElement.
Legend
Method
virtual
protected
abstract
Property
read only
Links
PegtopFormulas, Legend, Members, Methods, Properties


TPegtopFormulaFunction.Compile Method

Links
TPegtopFormulaFunction Class
PegtopMath
Contents | Index
Up | Next
TPegtopFormulaFunction.Compile Method
TPegtopFormulaFunction Class
Show All
procedure Compile(Code: TPegtopMacroAsmCode); override;
Description

This is Compile, a member of class TPegtopFormulaFunction.

Class

TPegtopFormulaFunction Class

Links
TPegtopFormulaFunction Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaFunction.Create Constructor

Links
TPegtopFormulaFunction Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormulaFunction.Create Constructor
TPegtopFormulaFunction Class
Show All
constructor Create(ANegative: Boolean);
Description

TPegtopFormulaFunction

Class

TPegtopFormulaFunction Class

Links
TPegtopFormulaFunction Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaFunction.GetPrio Method

Links
TPegtopFormulaFunction Class
PegtopMath
Contents | Index
Up | Previous
TPegtopFormulaFunction.GetPrio Method
TPegtopFormulaFunction Class
Show All
function GetPrio: Integer; override;
Description

This is GetPrio, a member of class TPegtopFormulaFunction.

Class

TPegtopFormulaFunction Class

Links
TPegtopFormulaFunction Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaVariable Class

Links
PegtopFormulas, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous | Next
TPegtopFormulaVariable Class
PegtopFormulas | Legend | Members | Methods | Properties
Show All
Class Hierarchy

TPegtopFormulaVariable = class(TPegtopFormulaElement);
File

PegtopFormulas

Description

TPegtopFormulaVariable is a variable of an expression.

Methods
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaVariable.
Create | TPegtopFormulaVariable
GetPrio | This is GetPrio, a member of class TPegtopFormulaVariable.
TPegtopFormulaElement Class
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaElement.
GetPrio | This is GetPrio, a member of class TPegtopFormulaElement.
Properties
Property | Description
DataAdr | This is DataAdr, a member of class TPegtopFormulaVariable.
TPegtopFormulaElement Class
Property | Description
Level | This is Level, a member of class TPegtopFormulaElement.
Negative | This is Negative, a member of class TPegtopFormulaElement.
Prev | This is Prev, a member of class TPegtopFormulaElement.
Prio | This is Prio, a member of class TPegtopFormulaElement.
Legend
Property
read only
Method
virtual
protected
abstract
Links
PegtopFormulas, Legend, Members, Methods, Properties


TPegtopFormulaVariable.DataAdr Property

Links
TPegtopFormulaVariable Class
PegtopMath
Contents | Index
Up | Next
TPegtopFormulaVariable.DataAdr Property
TPegtopFormulaVariable Class
Show All
property DataAdr: Integer;
Description

This is DataAdr, a member of class TPegtopFormulaVariable.

Class

TPegtopFormulaVariable Class

Links
TPegtopFormulaVariable Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaVariable.Compile Method

Links
TPegtopFormulaVariable Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormulaVariable.Compile Method
TPegtopFormulaVariable Class
Show All
procedure Compile(Code: TPegtopMacroAsmCode); override;
Description

This is Compile, a member of class TPegtopFormulaVariable.

Class

TPegtopFormulaVariable Class

Links
TPegtopFormulaVariable Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaVariable.Create Constructor

Links
TPegtopFormulaVariable Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopFormulaVariable.Create Constructor
TPegtopFormulaVariable Class
Show All
constructor Create(ADataAdr: Integer; ANegative: Boolean);
Description

TPegtopFormulaVariable

Class

TPegtopFormulaVariable Class

Links
TPegtopFormulaVariable Class
Copyright (c) 2005. All rights reserved.


TPegtopFormulaVariable.GetPrio Method

Links
TPegtopFormulaVariable Class
PegtopMath
Contents | Index
Up | Previous
TPegtopFormulaVariable.GetPrio Method
TPegtopFormulaVariable Class
Show All
function GetPrio: Integer; override;
Description

This is GetPrio, a member of class TPegtopFormulaVariable.

Class

TPegtopFormulaVariable Class

Links
TPegtopFormulaVariable Class
Copyright (c) 2005. All rights reserved.


TPegtopMacroAsmCode Class

Links
PegtopAssemblers, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous | Next
TPegtopMacroAsmCode Class
PegtopAssemblers | Legend | Members | Methods | Properties
Show All
Class Hierarchy

TPegtopMacroAsmCode = class(TPegtopAsmCode);
File

PegtopAssemblers

Description

TPegtopMacroAsmCode is an extension of TPegtopAsmCode and defines macros consisting of more than one asm instruction.

Methods
TPegtopCompilerCode Class
Method | Description
AddAddr | Add virtual address to code block.
AddCode | Add code byte to code block.
AddJump | Add jump to code block. The target label can either be added before or after this operation.
AddLabel | Add label to code block.
AddLine | Add line of text to code block as documentation of the machine code (usually this is asm code).
AddrToHex | Transform virtual address to hex string.
CleanUp | Clean up name spaces after finishing code creation. This method makes sure all name spaces are closed, and should be called before destroying TPegtopCompilerCode. It is not part of the destructor, because a destructor should never raise exceptions.
Clear | Clear code block.
CloseNameSpace | Close name space opened with OpenNameSpace.
Create | Create new TPegtopCompilerCode object , reinitializing data type alignment (see TPegtopCompilerData constructor).
DecIndent | Decrease indent width used when adding text lines.
Destroy | Destroy TPegtopCompilerCode object. You should call CleanUp (see there) before destroying a TPegtopCompilerCode object.
IncIndent | Increase indent width used when adding text lines.
OpenNameSpace | Open new name space. Name spaces can be nested.
TPegtopCompilerData Class
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.
Properties
TPegtopCompilerCode Class
Property | Description
Data | data block belonging to this code block
Lines | text lines of code block (for documentation, usually contains the asm instructions to generate the machine code)
TPegtopCompilerData Class
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)
Legend
Property
read only
Method
protected
virtual
Links
PegtopAssemblers, Legend, Members, Methods, Properties


TPegtopNamedAddress Class

Links
PegtopCompilers, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous | Next
TPegtopNamedAddress Class
PegtopCompilers | Legend | Members | Methods | Properties
Show All
Class Hierarchy

TPegtopNamedAddress = class;
File

PegtopCompilers

Description

TPegtopNamedAddress combines a virtual address with a name. TPegtopNamedAddress is only used internally by TPegtopNameSpace.

Methods
Method | Description
Create | Create new name TPegtopNamedAddress object.
Properties
Property | Description
Address | This is Address, a member of class TPegtopNamedAddress.
Name | This is Name, a member of class TPegtopNamedAddress.
Legend
Property
read only
Method
Links
PegtopCompilers, Legend, Members, Methods, Properties


TPegtopNamedAddress.Address Property

Links
TPegtopNamedAddress Class
PegtopMath
Contents | Index
Up | Next
TPegtopNamedAddress.Address Property
TPegtopNamedAddress Class
Show All
property Address: TPegtopVirtualAddr;
Description

This is Address, a member of class TPegtopNamedAddress.

Class

TPegtopNamedAddress Class

Links
TPegtopNamedAddress Class
Copyright (c) 2005. All rights reserved.


TPegtopNamedAddress.Name Property

Links
TPegtopNamedAddress Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopNamedAddress.Name Property
TPegtopNamedAddress Class
Show All
property Name: String;
Description

This is Name, a member of class TPegtopNamedAddress.

Class

TPegtopNamedAddress Class

Links
TPegtopNamedAddress Class
Copyright (c) 2005. All rights reserved.


TPegtopNamedAddress.Create Constructor

Links
TPegtopNamedAddress Class
PegtopMath
Contents | Index
Up | Previous
TPegtopNamedAddress.Create Constructor
TPegtopNamedAddress Class
Show All
constructor Create(AName: String; AAddress: TPegtopVirtualAddr);
Description

Create new name TPegtopNamedAddress object.

Class

TPegtopNamedAddress Class

Links
TPegtopNamedAddress Class
Copyright (c) 2005. All rights reserved.


TPegtopNamedAddressList Class

Links
PegtopCompilers, Legend, Members, Methods
PegtopMath
Contents | Index
Previous | Next
TPegtopNamedAddressList Class
PegtopCompilers | Legend | Members | Methods
Show All
Class Hierarchy

TPegtopNamedAddressList = class(TObjectList);
File

PegtopCompilers

Description

TPegtopNamedAddressList is a list of TPegtopNamedAddress objects. TPegtopNamedAddressList is only used internally by TPegtopNameSpace.

Methods
Method | Description
Find | Find TPegtopNamedAddress being part of this list by its name. If no item matches the name specified, nil is returned.
Legend
Method
Links
PegtopCompilers, Legend, Members, Methods


TPegtopNamedAddressList.Find Method

Links
TPegtopNamedAddressList Class
PegtopMath
Contents | Index
Up
TPegtopNamedAddressList.Find Method
TPegtopNamedAddressList Class
Show All
function Find(Name: String): TPegtopNamedAddress;
Description

Find TPegtopNamedAddress being part of this list by its name. If no item matches the name specified, nil is returned.

Class

TPegtopNamedAddressList Class

Links
TPegtopNamedAddressList Class
Copyright (c) 2005. All rights reserved.


TPegtopNameSpace Class

Links
PegtopCompilers, Legend, Members, Methods, Properties
PegtopMath
Contents | Index
Previous
TPegtopNameSpace Class
PegtopCompilers | Legend | Members | Methods | Properties
Show All
Class Hierarchy

TPegtopNameSpace = class;
File

PegtopCompilers

Description

TPegtopNameSpace holds all labels and unresolved jumps within a name space. TPegtopNameSpace is only used internally by TPegtopCompilerCode.

Methods
Method | Description
AddJump | Add jump to name space.
AddLabel | Add label to name space.
Create | Create new TPegtopNameSpace object.
Destroy | Destroy TPegtopNameSpace object.
LabelMissing | Return True if there are unresolved jumps (what means at least on label is missing).
ListJumps | Return list of jumps as a string.
ResolveJumps | Resolve all jumps to some label. Usually this method is called whenever a new label is added, to make sure all jumps defined before the label are adjusted.
Properties
Property | Description
Name | This is Name, a member of class TPegtopNameSpace.
Legend
Property
read only
Method
virtual
Links
PegtopCompilers, Legend, Members, Methods, Properties


TPegtopNameSpace.Name Property

Links
TPegtopNameSpace Class
PegtopMath
Contents | Index
Up | Next
TPegtopNameSpace.Name Property
TPegtopNameSpace Class
Show All
property Name: String;
Description

This is Name, a member of class TPegtopNameSpace.

Class

TPegtopNameSpace Class

Links
TPegtopNameSpace Class
Copyright (c) 2005. All rights reserved.


TPegtopNameSpace.AddJump Method

Links
TPegtopNameSpace Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopNameSpace.AddJump Method
TPegtopNameSpace Class
Show All
procedure AddJump(Name: String);
Description

Add jump to name space.

Class

TPegtopNameSpace Class

Links
TPegtopNameSpace Class
Copyright (c) 2005. All rights reserved.


TPegtopNameSpace.AddLabel Method

Links
TPegtopNameSpace Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopNameSpace.AddLabel Method
TPegtopNameSpace Class
Show All
procedure AddLabel(Name: String; Address: TPegtopVirtualAddr);
Description

Add label to name space.

Class

TPegtopNameSpace Class

Links
TPegtopNameSpace Class
Copyright (c) 2005. All rights reserved.


TPegtopNameSpace.Create Constructor

Links
TPegtopNameSpace Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopNameSpace.Create Constructor
TPegtopNameSpace Class
Show All
constructor Create(AName: String; ACode: TPegtopCompilerCode);
Description

Create new TPegtopNameSpace object.

Class

TPegtopNameSpace Class

Links
TPegtopNameSpace Class
Copyright (c) 2005. All rights reserved.


TPegtopNameSpace.Destroy Destructor

Links
TPegtopNameSpace Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopNameSpace.Destroy Destructor
TPegtopNameSpace Class
Show All
destructor Destroy; override;
Description

Destroy TPegtopNameSpace object.

Class

TPegtopNameSpace Class

Links
TPegtopNameSpace Class
Copyright (c) 2005. All rights reserved.


TPegtopNameSpace.LabelMissing Method

Links
TPegtopNameSpace Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopNameSpace.LabelMissing Method
TPegtopNameSpace Class
Show All
function LabelMissing: Boolean;
Description

Return True if there are unresolved jumps (what means at least on label is missing).

Class

TPegtopNameSpace Class

Links
TPegtopNameSpace Class
Copyright (c) 2005. All rights reserved.


TPegtopNameSpace.ListJumps Method

Links
TPegtopNameSpace Class
PegtopMath
Contents | Index
Up | Previous | Next
TPegtopNameSpace.ListJumps Method
TPegtopNameSpace Class
Show All
function ListJumps: String;
Description

Return list of jumps as a string.

Class

TPegtopNameSpace Class

Links
TPegtopNameSpace Class
Copyright (c) 2005. All rights reserved.


TPegtopNameSpace.ResolveJumps Method

Links
TPegtopNameSpace Class
PegtopMath
Contents | Index
Up | Previous
TPegtopNameSpace.ResolveJumps Method
TPegtopNameSpace Class
Show All
procedure ResolveJumps(ToLabel: TPegtopNamedAddress);
Description

Resolve all jumps to some label. Usually this method is called whenever a new label is added, to make sure all jumps defined before the label are adjusted.

Class

TPegtopNameSpace Class

Links
TPegtopNameSpace Class
Copyright (c) 2005. All rights reserved.


IsInfinite Function

Links
PegtopFormulas
PegtopMath
Contents | Index
Next
IsInfinite Function
PegtopFormulas
Show All
function IsInfinite(V: Double): Boolean;
File

PegtopFormulas

Description

IsInfinite returns True for infinite values.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


IsInfiniteOrNaN Function

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
IsInfiniteOrNaN Function
PegtopFormulas
Show All
function IsInfiniteOrNaN(V: Double): Boolean;
File

PegtopFormulas

Description

IsInfiniteOrNaN returns True for infinite values or values that are not a number.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


IsNaN Function

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
IsNaN Function
PegtopFormulas
Show All
function IsNaN(V: Double): Boolean;
File

PegtopFormulas

Description

IsNan returns True for values that are not a number.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


IsNegInfinite Function

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
IsNegInfinite Function
PegtopFormulas
Show All
function IsNegInfinite(V: Double): Boolean;
File

PegtopFormulas

Description

IsNegInfinite returns true for negative infinite numbers.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


IsNegZero Function

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
IsNegZero Function
PegtopFormulas
Show All
function IsNegZero(V: Double): Boolean;
File

PegtopFormulas

Description

IsNegZero returns true for negative zeros (floating point numbers contain positive and negative zeros).

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


IsPosInfinite Function

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
IsPosInfinite Function
PegtopFormulas
Show All
function IsPosInfinite(V: Double): Boolean;
File

PegtopFormulas

Description

IsPosInfinite returns true for positive infinite numbers.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


IsPosZero Function

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
IsPosZero Function
PegtopFormulas
Show All
function IsPosZero(V: Double): Boolean;
File

PegtopFormulas

Description

IsPosZero returns true for positive zeros (floating point numbers contain positive and negative zeros).

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


IsZero Function

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous
IsZero Function
PegtopFormulas
Show All
function IsZero(V: Double): Boolean;
File

PegtopFormulas

Description

IsZero returns true for zero.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


TCharClass Enumeration

Links
PegtopFormulas
PegtopMath
Contents | Index
Next
TCharClass Enumeration
PegtopFormulas
Show All
TCharClass = (ccUnknown, ccSpace, ccAlpha, ccDigit, ccDecSep, ccOperator, ccBraOpen, ccBraClose);
File

PegtopFormulas

Description

This is record TCharClass.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


TPegtopCompilerDataType Enumeration

Links
PegtopCompilers
PegtopMath
Contents | Index
Previous | Next
TPegtopCompilerDataType Enumeration
PegtopCompilers
Show All
TPegtopCompilerDataType = (cdtByte, cdtDouble, cdtInt64, cdtLongint, cdtSmallint, cdtWord);
File

PegtopCompilers

Description

TPegtopCompilerDataType defines the data types the compiler works with. TPegtopCompilerDataType is only used internally (for memory alignment).

Links
PegtopCompilers
Copyright (c) 2005. All rights reserved.


TPegtopFormulaOperator Enumeration

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
TPegtopFormulaOperator Enumeration
PegtopFormulas
Show All
TPegtopFormulaOperator = (opNone, opAdd, opSub, opMul, opDiv, opMod, opPow);
File

PegtopFormulas

Description

TPegtopFormulaOperator identifies a mathematical operator of an expression.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


TPegtopFormulaOption Enumeration

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
TPegtopFormulaOption Enumeration
PegtopFormulas
Show All
TPegtopFormulaOption = (pfoAutoCloseBrackets, pfoNationalDecimalSeparator);
File

PegtopFormulas

Description

TPegtopFormulaOption identifies options of TPegtopFormula.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


TPegtopMathError Enumeration

Links
PegtopAssemblers
PegtopMath
Contents | Index
Previous | Next
TPegtopMathError Enumeration
PegtopAssemblers
Show All
TPegtopMathError = (pmeInvalidOp, pmeDenormal, pmeDivByZero, pmeOverflow, pmeUnderflow, pmePrecision);
File

PegtopAssemblers

Description

TPegtopMathError identifies the possible errors detected by the 80x87 FPU.

Links
PegtopAssemblers
Copyright (c) 2005. All rights reserved.


TPegtopMathInfinity Enumeration

Links
PegtopAssemblers
PegtopMath
Contents | Index
Previous | Next
TPegtopMathInfinity Enumeration
PegtopAssemblers
Show All
TPegtopMathInfinity = (pmiProjective, pmiAffine);
File

PegtopAssemblers

Description

TPegtopMathInfinity defines infinity control. It is only used for compatability with the 80287 FPU and is a reserved flag now.

Links
PegtopAssemblers
Copyright (c) 2005. All rights reserved.


TPegtopMathPrecision Enumeration

Links
PegtopAssemblers
PegtopMath
Contents | Index
Previous | Next
TPegtopMathPrecision Enumeration
PegtopAssemblers
Show All
TPegtopMathPrecision = (pmp24bit, pmp53bit, pmp64bit);
File

PegtopAssemblers

Description

TPegtopMathPrecision identifies the precision used by the 80x87 FPU.

  • pmp24bit is single presision (24 bit mantissa)
  • pmp53bit is double presision (53 bit mantissa)
  • pmp64bit is extended presision (64 bit mantissa)

TPegtopMathPrecision is used to control the precision used by the FPU internally. All FPU registers have 80 bits, using up to 64 bits for the mantissa. By default the highest value (64 bit mantissa) is used, but to simulate less precision another value can be selected. The precision doesn't influence execution speed of most operations, but less precision can be faster for some operations (only division and square root are affected as far as I know).

Links
PegtopAssemblers
Copyright (c) 2005. All rights reserved.


TPegtopMathReg Enumeration

Links
PegtopAssemblers
PegtopMath
Contents | Index
Previous | Next
TPegtopMathReg Enumeration
PegtopAssemblers
Show All
TPegtopMathReg = (st0, st1, st2, st3, st4, st5, st6, st7);
File

PegtopAssemblers

Description

TPegtopMathReg identifies the 80x87 FPU registers.

Links
PegtopAssemblers
Copyright (c) 2005. All rights reserved.


TPegtopMathRounding Enumeration

Links
PegtopAssemblers
PegtopMath
Contents | Index
Previous | Next
TPegtopMathRounding Enumeration
PegtopAssemblers
Show All
TPegtopMathRounding = (pmrDefault, pmrNearest, pmrDown, pmrUp, pmrToZero);
File

PegtopAssemblers

Description

TPegtopMathRounding identifies the rounding method used by the 80x87 FPU.

Links
PegtopAssemblers
Copyright (c) 2005. All rights reserved.


TPegtopProcReg Enumeration

Links
PegtopAssemblers
PegtopMath
Contents | Index
Previous | Next
TPegtopProcReg Enumeration
PegtopAssemblers
Show All
TPegtopProcReg = (regAX, regBX, regCX, regDX, regSP, regBP, regSI, regDI, regEAX, regEBX, regECX, regEDX, regESP, regEBP, regESI, regEDI);
File

PegtopAssemblers

Description

TPegtopProcReg identifies 16 bit and 32 bit CPU registers.

Links
PegtopAssemblers
Copyright (c) 2005. All rights reserved.


TPegtopProcRegType Enumeration

Links
PegtopAssemblers
PegtopMath
Contents | Index
Previous
TPegtopProcRegType Enumeration
PegtopAssemblers
Show All
TPegtopProcRegType = (prt16bit, prt32bit);
File

PegtopAssemblers

Description

TPegtopProcRegType identifies the type of a CPU register (16 or 32 bit)

Links
PegtopAssemblers
Copyright (c) 2005. All rights reserved.


TOperatorPrecedence Type

Links
PegtopFormulas
PegtopMath
Contents | Index
Next
TOperatorPrecedence Type
PegtopFormulas
Show All
TOperatorPrecedence = 0..BracketPrecedence-1;
File

PegtopFormulas

Description

This is type TOperatorPrecedence.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


TPegtopFormulaOptions Type

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous | Next
TPegtopFormulaOptions Type
PegtopFormulas
Show All
TPegtopFormulaOptions = set of TPegtopFormulaOption;
File

PegtopFormulas

Description

TPegtopFormulaOptions is a set of TPegtopFormulaOption.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


TPegtopMathErrors Type

Links
PegtopAssemblers
PegtopMath
Contents | Index
Previous | Next
TPegtopMathErrors Type
PegtopAssemblers
Show All
TPegtopMathErrors = set of TPegtopMathError;
File

PegtopAssemblers

Description

TPegtopMathErrors is a set of TPegtopMathError.

Links
PegtopAssemblers
Copyright (c) 2005. All rights reserved.


TPegtopVirtualAddr Type

Links
PegtopCompilers
PegtopMath
Contents | Index
Previous | Next
TPegtopVirtualAddr Type
PegtopCompilers
Show All
TPegtopVirtualAddr = Integer;
File

PegtopCompilers

Description

TPegtopVirtualAddr defines an address relative to some start address (usually the start address of a TPegtopCompilerData data or code block).

Links
PegtopCompilers
Copyright (c) 2005. All rights reserved.


TPrecedence Type

Links
PegtopFormulas
PegtopMath
Contents | Index
Previous
TPrecedence Type
PegtopFormulas
Show All
TPrecedence = 0..BracketPrecedence;
File

PegtopFormulas

Description

This is type TPrecedence.

Links
PegtopFormulas
Copyright (c) 2005. All rights reserved.


PegtopAssemblers.pas

Links
Classes, Enumerations, Types
PegtopMath
Contents | Index
Next
PegtopAssemblers.pas
Classes | Enumerations | Types
Show All

TPegtopAsmCode extends TPegtopCompilerCode with assembler instructions (only the ones that are relevant for TPegtopFormulaCompiler). TPegtopMacroAsmCode extends TPegtopAsmCode with macros and procedure calls.

Version

1.02

Classes
Class | Description
EPegtopAsmInvalidOperand | EPegtopAsmInvalidOperand is raised when an asm operator expects another operand then specified (for example when a 16 bit register is used when a 32 bit register is expected).
TPegtopAsmCode | TPegtopAsmCode is based on TPegtopCompilerCode and defines all (for TPegtopFormulaCompiler) important asm instructions.
TPegtopMacroAsmCode | TPegtopMacroAsmCode is an extension of TPegtopAsmCode and defines macros consisting of more than one asm instruction.
Enumerations
Enumeration
Description
TPegtopMathError
TPegtopMathError identifies the possible errors detected by the 80x87 FPU.
TPegtopMathInfinity
TPegtopMathInfinity defines infinity control. It is only used for compatability with the 80287 FPU and is a reserved flag now.
TPegtopMathPrecision
TPegtopMathPrecision identifies the precision used by the 80x87 FPU.

  • pmp24bit is single presision (24 bit mantissa)
  • pmp53bit is double presision (53 bit mantissa)
  • pmp64bit is extended presision (64 bit mantissa)

TPegtopMathPrecision is used to control the precision used by the FPU internally. All FPU registers have 80 bits, using up to 64 bits for the mantissa. By default the highest value (64 bit mantissa) is used, but to simulate less precision another value can be selected. The precision doesn't influence execution speed of most operations, but less precision can be faster for some operations (only division and square root are affected as far as I know).

TPegtopMathReg
TPegtopMathReg identifies the 80x87 FPU registers.
TPegtopMathRounding
TPegtopMathRounding identifies the rounding method used by the 80x87 FPU.
TPegtopProcReg
TPegtopProcReg identifies 16 bit and 32 bit CPU registers.
TPegtopProcRegType
TPegtopProcRegType identifies the type of a CPU register (16 or 32 bit)
Types
Type | Description
TPegtopMathErrors | TPegtopMathErrors is a set of TPegtopMathError.
Links
Classes, Enumerations, Types
Copyright (c) 2005. All rights reserved.


PegtopCompilers.pas

Links
Classes, Enumerations, Types
PegtopMath
Contents | Index
Previous | Next
PegtopCompilers.pas
Classes | Enumerations | Types
Show All

TPegtopCompilerData is a container of dynamic size for data of different types. TPegtopCompilerCode is a container of dynamic size for machine code. It can be filled with machine code and is base class of TPegtopAsmCode (see PegtopAssembler.pas) and has functions for jumps to labels.

Version

1.01

Classes
Class | Description
EPegtopCompiler | EPegtopCompiler is the base class for all exceptions raised by TPegtopCompilerData, TPegtopCompilerCode, TPegtopAsmCode and other classes involved compiling to machine code.
TPegtopCompilerCode | TPegtopCompilerCode is a special TPegtopCompilerData data block used to store machine code. It features name spaces, which can be used to define labels and jumps only valid within a name space (another name space can use labels with the same names without conflicts). TPegtopCompilerCode also holds a string list with the asm instructions used to generate the machine code (the creator of the machine code is responsible for adding this information correctly).
TPegtopCompilerData | TPegtopCompilerData defines a block of data, either for variables or for code (see TPegtopCompilerCode).
TPegtopNamedAddress | TPegtopNamedAddress combines a virtual address with a name. TPegtopNamedAddress is only used internally by TPegtopNameSpace.
TPegtopNamedAddressList | TPegtopNamedAddressList is a list of TPegtopNamedAddress objects. TPegtopNamedAddressList is only used internally by TPegtopNameSpace.
TPegtopNameSpace | TPegtopNameSpace holds all labels and unresolved jumps within a name space. TPegtopNameSpace is only used internally by TPegtopCompilerCode.
Enumerations
Enumeration | Description
TPegtopCompilerDataType | TPegtopCompilerDataType defines the data types the compiler works with. TPegtopCompilerDataType is only used internally (for memory alignment).
Types
Type | Description
TPegtopVirtualAddr | TPegtopVirtualAddr defines an address relative to some start address (usually the start address of a TPegtopCompilerData data or code block).
Links
Classes, Enumerations, Types
Copyright (c) 2005. All rights reserved.


PegtopFormulas.pas

Links
Classes, Enumerations, Functions, Types
PegtopMath
Contents | Index
Previous
PegtopFormulas.pas
Classes | Enumerations | Functions | Types
Show All

TPegtopFormula is a fast expression evaluator. The formula (which is given as a string at runtime) is parsed and compiled once, so evaluation is done with speed of assembler code (comparable to the speed of Delphi code). Arguments and result have double precision (the default 64 bit double type), all calculation is done with the math coprocessor (80x87 instructions).

Version

1.02

Classes
Class | Description
EPegtopFormula | EPegtopFormula is the base class for all exceptions raised by TPegtopFormula and other classes used by TPegtopFormula (except of the compiler, which raises EPegtopCompiler, what should rarely happen).
EPegtopFormulaArgument | EPegtopFormulaArgument indicates that wrong arguments were given to TPegtopFormula (for example too many arguments or arguments with wrong names).
EPegtopFormulaBadSpecifier | EPegtopFormulaBadSpecifier indicates a bad specifier while parsing an expression.
EPegtopFormulaInvalid | EPegtopFormulaInvalid is raised for invalid expressions.
EPegtopFormulaParameter | EPegtopFormulaParse indicates that something is wrong with the parameters (for example two identical names are used).
EPegtopFormulaParse | EPegtopFormulaParse indicates an exception while parsing an expression.
TPegtopFormula | TPegtopFormula is a fast expression evaluator component.
TPegtopFormulaCompiler | TPegtopFormulaCompiler is used to compile an expression to machine code.
TPegtopFormulaElement | TPegtopFormulaElement is an element of an expression, like a TPegtopFormulaVariable or a TPegtopFormulaFunction.
TPegtopFormulaFunction | TPegtopFormulaFunction is a function of an expression.
TPegtopFormulaVariable | TPegtopFormulaVariable is a variable of an expression.
Enumerations
Enumeration | Description
TCharClass | This is record TCharClass.
TPegtopFormulaOperator | TPegtopFormulaOperator identifies a mathematical operator of an expression.
TPegtopFormulaOption | TPegtopFormulaOption identifies options of TPegtopFormula.
Functions
Function | Description
IsInfinite | IsInfinite returns True for infinite values.
IsInfiniteOrNaN | IsInfiniteOrNaN returns True for infinite values or values that are not a number.
IsNaN | IsNan returns True for values that are not a number.
IsNegInfinite | IsNegInfinite returns true for negative infinite numbers.
IsNegZero | IsNegZero returns true for negative zeros (floating point numbers contain positive and negative zeros).
IsPosInfinite | IsPosInfinite returns true for positive infinite numbers.
IsPosZero | IsPosZero returns true for positive zeros (floating point numbers contain positive and negative zeros).
IsZero | IsZero returns true for zero.
Types
Type | Description
TOperatorPrecedence | This is type TOperatorPrecedence.
TPegtopFormulaOptions | TPegtopFormulaOptions is a set of TPegtopFormulaOption.
TPrecedence | This is type TPrecedence.
Links
Classes, Enumerations, Functions, Types
Usage

Before you assign a string (like 'x+2') to the Formula property, you have to define all parameters (like Parameters.Add('x')). The formula is compiled automatically before the first evaluation is done (or by calling Compile). You can either set arguments by index (like SetArg(0, 2.3), where the first parameter has index = 0) or by name (like SetArg('x', 2.3)), which is a bit slower, or directly by calling the overloaded Eval method with parameters (like Eval([2.3, 7] to set the first parameter to 2.3 and the second to 7).


Legend

Contents | Index
Legend
EPegtopAsmInvalidOperand Class
Legend
Method
Copyright (c) 2005. All rights reserved.


EPegtopAsmInvalidOperand Class Members

Contents | Index
EPegtopAsmInvalidOperand Class Members
EPegtopAsmInvalidOperand Class | Legend
Members
Methods
Method | Description
CreateProp | EPegtopAsmInvalidArg


Members

Contents | Index
Legend
Method


EPegtopAsmInvalidOperand Class Methods

Contents | Index
EPegtopAsmInvalidOperand Class Methods
EPegtopAsmInvalidOperand Class | Legend
Methods
Method | Description
CreateProp | EPegtopAsmInvalidArg


Methods

Contents | Index
Legend
Method


Legend

Contents | Index
Legend
EPegtopFormulaBadSpecifier Class
Legend
Property
read only
Method


EPegtopFormulaBadSpecifier Class Members

Contents | Index
EPegtopFormulaBadSpecifier Class Members
EPegtopFormulaBadSpecifier Class | Legend
Members
Properties
Property | Description
Specifier | This is Specifier, a member of class EPegtopFormulaBadSpecifier.
EPegtopFormulaParse Class
Property | Description
Expected | This is Expected, a member of class EPegtopFormulaParse.
Expression | This is Expression, a member of class EPegtopFormulaParse.
Invalid | This is Invalid, a member of class EPegtopFormulaParse.
Position | This is Position, a member of class EPegtopFormulaParse.
Methods
Method | Description
CreateProp | EPegtopFormulaBadSpecifier
EPegtopFormulaParse Class
Method | Description
CreateProp | EPegtopFormulaParse


Members

Contents | Index
Legend
Property
read only
Method


EPegtopFormulaBadSpecifier Class Methods

Contents | Index
EPegtopFormulaBadSpecifier Class Methods
EPegtopFormulaBadSpecifier Class | Legend
Methods
Method | Description
CreateProp | EPegtopFormulaBadSpecifier
EPegtopFormulaParse Class
Method | Description
CreateProp | EPegtopFormulaParse


EPegtopFormulaBadSpecifier Class Properties

Contents | Index
EPegtopFormulaBadSpecifier Class Properties
EPegtopFormulaBadSpecifier Class | Legend
Properties
Property | Description
Specifier | This is Specifier, a member of class EPegtopFormulaBadSpecifier.
EPegtopFormulaParse Class
Property | Description
Expected | This is Expected, a member of class EPegtopFormulaParse.
Expression | This is Expression, a member of class EPegtopFormulaParse.
Invalid | This is Invalid, a member of class EPegtopFormulaParse.
Position | This is Position, a member of class EPegtopFormulaParse.


Properties

Contents | Index
Legend
Property
read only


Legend

Contents | Index
Legend
EPegtopFormulaParse Class
Legend
Property
read only
Method


EPegtopFormulaParse Class Members

Contents | Index
EPegtopFormulaParse Class Members
EPegtopFormulaParse Class | Legend
Members
Properties
Property | Description
Expected | This is Expected, a member of class EPegtopFormulaParse.
Expression | This is Expression, a member of class EPegtopFormulaParse.
Invalid | This is Invalid, a member of class EPegtopFormulaParse.
Position | This is Position, a member of class EPegtopFormulaParse.
Methods
Method | Description
CreateProp | EPegtopFormulaParse


EPegtopFormulaParse Class Methods

Contents | Index
EPegtopFormulaParse Class Methods
EPegtopFormulaParse Class | Legend
Methods
Method | Description
CreateProp | EPegtopFormulaParse


EPegtopFormulaParse Class Properties

Contents | Index
EPegtopFormulaParse Class Properties
EPegtopFormulaParse Class | Legend
Properties
Property | Description
Expected | This is Expected, a member of class EPegtopFormulaParse.
Expression | This is Expression, a member of class EPegtopFormulaParse.
Invalid | This is Invalid, a member of class EPegtopFormulaParse.
Position | This is Position, a member of class EPegtopFormulaParse.


PegtopAssemblers.pas Classes

Contents | Index
PegtopAssemblers.pas Classes
PegtopAssemblers.pas
Classes
Class | Description
EPegtopAsmInvalidOperand | EPegtopAsmInvalidOperand is raised when an asm operator expects another operand then specified (for example when a 16 bit register is used when a 32 bit register is expected).
TPegtopAsmCode | TPegtopAsmCode is based on TPegtopCompilerCode and defines all (for TPegtopFormulaCompiler) important asm instructions.
TPegtopMacroAsmCode | TPegtopMacroAsmCode is an extension of TPegtopAsmCode and defines macros consisting of more than one asm instruction.


PegtopAssemblers.pas Enumerations

Contents | Index
PegtopAssemblers.pas Enumerations
PegtopAssemblers.pas
Enumerations
Enumeration
Description
TPegtopMathError
TPegtopMathError identifies the possible errors detected by the 80x87 FPU.
TPegtopMathInfinity
TPegtopMathInfinity defines infinity control. It is only used for compatability with the 80287 FPU and is a reserved flag now.
TPegtopMathPrecision
TPegtopMathPrecision identifies the precision used by the 80x87 FPU.

  • pmp24bit is single presision (24 bit mantissa)
  • pmp53bit is double presision (53 bit mantissa)
  • pmp64bit is extended presision (64 bit mantissa)

TPegtopMathPrecision is used to control the precision used by the FPU internally. All FPU registers have 80 bits, using up to 64 bits for the mantissa. By default the highest value (64 bit mantissa) is used, but to simulate less precision another value can be selected. The precision doesn't influence execution speed of most operations, but less precision can be faster for some operations (only division and square root are affected as far as I know).

TPegtopMathReg
TPegtopMathReg identifies the 80x87 FPU registers.
TPegtopMathRounding
TPegtopMathRounding identifies the rounding method used by the 80x87 FPU.
TPegtopProcReg
TPegtopProcReg identifies 16 bit and 32 bit CPU registers.
TPegtopProcRegType
TPegtopProcRegType identifies the type of a CPU register (16 or 32 bit)


PegtopAssemblers.pas Types

Contents | Index
PegtopAssemblers.pas Types
PegtopAssemblers.pas
Types
Type | Description
TPegtopMathErrors | TPegtopMathErrors is a set of TPegtopMathError.


PegtopCompilers.pas Classes

Contents | Index
PegtopCompilers.pas Classes
PegtopCompilers.pas
Classes
Class | Description
EPegtopCompiler | EPegtopCompiler is the base class for all exceptions raised by TPegtopCompilerData, TPegtopCompilerCode, TPegtopAsmCode and other classes involved compiling to machine code.
TPegtopCompilerCode | TPegtopCompilerCode is a special TPegtopCompilerData data block used to store machine code. It features name spaces, which can be used to define labels and jumps only valid within a name space (another name space can use labels with the same names without conflicts). TPegtopCompilerCode also holds a string list with the asm instructions used to generate the machine code (the creator of the machine code is responsible for adding this information correctly).
TPegtopCompilerData | TPegtopCompilerData defines a block of data, either for variables or for code (see TPegtopCompilerCode).
TPegtopNamedAddress | TPegtopNamedAddress combines a virtual address with a name. TPegtopNamedAddress is only used internally by TPegtopNameSpace.
TPegtopNamedAddressList | TPegtopNamedAddressList is a list of TPegtopNamedAddress objects. TPegtopNamedAddressList is only used internally by TPegtopNameSpace.
TPegtopNameSpace | TPegtopNameSpace holds all labels and unresolved jumps within a name space. TPegtopNameSpace is only used internally by TPegtopCompilerCode.


PegtopCompilers.pas Enumerations

Contents | Index
PegtopCompilers.pas Enumerations
PegtopCompilers.pas
Enumerations
Enumeration | Description
TPegtopCompilerDataType | TPegtopCompilerDataType defines the data types the compiler works with. TPegtopCompilerDataType is only used internally (for memory alignment).


PegtopCompilers.pas Types

Contents | Index
PegtopCompilers.pas Types
PegtopCompilers.pas
Types
Type | Description
TPegtopVirtualAddr | TPegtopVirtualAddr defines an address relative to some start address (usually the start address of a TPegtopCompilerData data or code block).


PegtopFormulas.pas Classes

Contents | Index
PegtopFormulas.pas Classes
PegtopFormulas.pas
Classes
Class | Description
EPegtopFormula | EPegtopFormula is the base class for all exceptions raised by TPegtopFormula and other classes used by TPegtopFormula (except of the compiler, which raises EPegtopCompiler, what should rarely happen).
EPegtopFormulaArgument | EPegtopFormulaArgument indicates that wrong arguments were given to TPegtopFormula (for example too many arguments or arguments with wrong names).
EPegtopFormulaBadSpecifier | EPegtopFormulaBadSpecifier indicates a bad specifier while parsing an expression.
EPegtopFormulaInvalid | EPegtopFormulaInvalid is raised for invalid expressions.
EPegtopFormulaParameter | EPegtopFormulaParse indicates that something is wrong with the parameters (for example two identical names are used).
EPegtopFormulaParse | EPegtopFormulaParse indicates an exception while parsing an expression.
TPegtopFormula | TPegtopFormula is a fast expression evaluator component.
TPegtopFormulaCompiler | TPegtopFormulaCompiler is used to compile an expression to machine code.
TPegtopFormulaElement | TPegtopFormulaElement is an element of an expression, like a TPegtopFormulaVariable or a TPegtopFormulaFunction.
TPegtopFormulaFunction | TPegtopFormulaFunction is a function of an expression.
TPegtopFormulaVariable | TPegtopFormulaVariable is a variable of an expression.


PegtopFormulas.pas Enumerations

Contents | Index
PegtopFormulas.pas Enumerations
PegtopFormulas.pas
Enumerations
Enumeration | Description
TCharClass | This is record TCharClass.
TPegtopFormulaOperator | TPegtopFormulaOperator identifies a mathematical operator of an expression.
TPegtopFormulaOption | TPegtopFormulaOption identifies options of TPegtopFormula.


PegtopFormulas.pas Functions

Contents | Index
PegtopFormulas.pas Functions
PegtopFormulas.pas
Functions
Function | Description
IsInfinite | IsInfinite returns True for infinite values.
IsInfiniteOrNaN | IsInfiniteOrNaN returns True for infinite values or values that are not a number.
IsNaN | IsNan returns True for values that are not a number.
IsNegInfinite | IsNegInfinite returns true for negative infinite numbers.
IsNegZero | IsNegZero returns true for negative zeros (floating point numbers contain positive and negative zeros).
IsPosInfinite | IsPosInfinite returns true for positive infinite numbers.
IsPosZero | IsPosZero returns true for positive zeros (floating point numbers contain positive and negative zeros).
IsZero | IsZero returns true for zero.


PegtopFormulas.pas Types

Contents | Index
PegtopFormulas.pas Types
PegtopFormulas.pas
Types
Type | Description
TOperatorPrecedence | This is type TOperatorPrecedence.
TPegtopFormulaOptions | TPegtopFormulaOptions is a set of TPegtopFormulaOption.
TPrecedence | This is type TPrecedence.


Legend

Contents | Index
Legend
TPegtopAsmCode Class
Legend
Property
read only
Method
protected
virtual


TPegtopAsmCode Class Members

Contents | Index
TPegtopAsmCode Class Members
TPegtopAsmCode Class | Legend
Members
Properties
TPegtopCompilerCode Class
Property | Description
Data | data block belonging to this code block
Lines | text lines of code block (for documentation, usually contains the asm instructions to generate the machine code)
TPegtopCompilerData Class
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)
Methods
TPegtopCompilerCode Class
Method | Description
AddAddr | Add virtual address to code block.
AddCode | Add code byte to code block.
AddJump | Add jump to code block. The target label can either be added before or after this operation.
AddLabel | Add label to code block.
AddLine | Add line of text to code block as documentation of the machine code (usually this is asm code).
AddrToHex | Transform virtual address to hex string.
CleanUp | Clean up name spaces after finishing code creation. This method makes sure all name spaces are closed, and should be called before destroying TPegtopCompilerCode. It is not part of the destructor, because a destructor should never raise exceptions.
Clear | Clear code block.
CloseNameSpace | Close name space opened with OpenNameSpace.
Create | Create new TPegtopCompilerCode object , reinitializing data type alignment (see TPegtopCompilerData constructor).
DecIndent | Decrease indent width used when adding text lines.
Destroy | Destroy TPegtopCompilerCode object. You should call CleanUp (see there) before destroying a TPegtopCompilerCode object.
IncIndent | Increase indent width used when adding text lines.
OpenNameSpace | Open new name space. Name spaces can be nested.
TPegtopCompilerData Class
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.


Members

Contents | Index
Legend
Property
read only
Method
protected
virtual


TPegtopAsmCode Class Methods

Contents | Index
TPegtopAsmCode Class Methods
TPegtopAsmCode Class | Legend
Methods
TPegtopCompilerCode Class
Method | Description
AddAddr | Add virtual address to code block.
AddCode | Add code byte to code block.
AddJump | Add jump to code block. The target label can either be added before or after this operation.
AddLabel | Add label to code block.
AddLine | Add line of text to code block as documentation of the machine code (usually this is asm code).
AddrToHex | Transform virtual address to hex string.
CleanUp | Clean up name spaces after finishing code creation. This method makes sure all name spaces are closed, and should be called before destroying TPegtopCompilerCode. It is not part of the destructor, because a destructor should never raise exceptions.
Clear | Clear code block.
CloseNameSpace | Close name space opened with OpenNameSpace.
Create | Create new TPegtopCompilerCode object , reinitializing data type alignment (see TPegtopCompilerData constructor).
DecIndent | Decrease indent width used when adding text lines.
Destroy | Destroy TPegtopCompilerCode object. You should call CleanUp (see there) before destroying a TPegtopCompilerCode object.
IncIndent | Increase indent width used when adding text lines.
OpenNameSpace | Open new name space. Name spaces can be nested.
TPegtopCompilerData Class
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.


Methods

Contents | Index
Legend
Method
protected
virtual


TPegtopAsmCode Class Properties

Contents | Index
TPegtopAsmCode Class Properties
TPegtopAsmCode Class | Legend
Properties
TPegtopCompilerCode Class
Property | Description
Data | data block belonging to this code block
Lines | text lines of code block (for documentation, usually contains the asm instructions to generate the machine code)
TPegtopCompilerData Class
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)


Legend

Contents | Index
Legend
TPegtopCompilerCode Class
Legend
Property
read only
Method
protected
virtual


TPegtopCompilerCode Class Members

Contents | Index
TPegtopCompilerCode Class Members
TPegtopCompilerCode Class | Legend
Members
Properties
Property | Description
Data | data block belonging to this code block
Lines | text lines of code block (for documentation, usually contains the asm instructions to generate the machine code)
TPegtopCompilerData Class
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)
Methods
Method | Description
AddAddr | Add virtual address to code block.
AddCode | Add code byte to code block.
AddJump | Add jump to code block. The target label can either be added before or after this operation.
AddLabel | Add label to code block.
AddLine | Add line of text to code block as documentation of the machine code (usually this is asm code).
AddrToHex | Transform virtual address to hex string.
CleanUp | Clean up name spaces after finishing code creation. This method makes sure all name spaces are closed, and should be called before destroying TPegtopCompilerCode. It is not part of the destructor, because a destructor should never raise exceptions.
Clear | Clear code block.
CloseNameSpace | Close name space opened with OpenNameSpace.
Create | Create new TPegtopCompilerCode object , reinitializing data type alignment (see TPegtopCompilerData constructor).
DecIndent | Decrease indent width used when adding text lines.
Destroy | Destroy TPegtopCompilerCode object. You should call CleanUp (see there) before destroying a TPegtopCompilerCode object.
IncIndent | Increase indent width used when adding text lines.
OpenNameSpace | Open new name space. Name spaces can be nested.
TPegtopCompilerData Class
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.


TPegtopCompilerCode Class Methods

Contents | Index
TPegtopCompilerCode Class Methods
TPegtopCompilerCode Class | Legend
Methods
Method | Description
AddAddr | Add virtual address to code block.
AddCode | Add code byte to code block.
AddJump | Add jump to code block. The target label can either be added before or after this operation.
AddLabel | Add label to code block.
AddLine | Add line of text to code block as documentation of the machine code (usually this is asm code).
AddrToHex | Transform virtual address to hex string.
CleanUp | Clean up name spaces after finishing code creation. This method makes sure all name spaces are closed, and should be called before destroying TPegtopCompilerCode. It is not part of the destructor, because a destructor should never raise exceptions.
Clear | Clear code block.
CloseNameSpace | Close name space opened with OpenNameSpace.
Create | Create new TPegtopCompilerCode object , reinitializing data type alignment (see TPegtopCompilerData constructor).
DecIndent | Decrease indent width used when adding text lines.
Destroy | Destroy TPegtopCompilerCode object. You should call CleanUp (see there) before destroying a TPegtopCompilerCode object.
IncIndent | Increase indent width used when adding text lines.
OpenNameSpace | Open new name space. Name spaces can be nested.
TPegtopCompilerData Class
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.


TPegtopCompilerCode Class Properties

Contents | Index
TPegtopCompilerCode Class Properties
TPegtopCompilerCode Class | Legend
Properties
Property | Description
Data | data block belonging to this code block
Lines | text lines of code block (for documentation, usually contains the asm instructions to generate the machine code)
TPegtopCompilerData Class
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)


Legend

Contents | Index
Legend
TPegtopCompilerData Class
Legend
Property
read only
Method
virtual


TPegtopCompilerData Class Members

Contents | Index
TPegtopCompilerData Class Members
TPegtopCompilerData Class | Legend
Members
Properties
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)
Methods
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.


Members

Contents | Index
Legend
Property
read only
Method
virtual


TPegtopCompilerData Class Methods

Contents | Index
TPegtopCompilerData Class Methods
TPegtopCompilerData Class | Legend
Methods
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.


Methods

Contents | Index
Legend
Method
virtual


TPegtopCompilerData Class Properties

Contents | Index
TPegtopCompilerData Class Properties
TPegtopCompilerData Class | Legend
Properties
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)


Legend

Contents | Index
Legend
TPegtopFormula Class
Legend
Property
read only
Method
virtual


TPegtopFormula Class Members

Contents | Index
TPegtopFormula Class Members
TPegtopFormula Class | Legend
Members
Properties
Property | Description
CodeLines | This is CodeLines, a member of class TPegtopFormula.
CodeSize | This is CodeSize, a member of class TPegtopFormula.
Expression | mathematical formula expression as a string (is compiled by calling Compile or automatically when needed)
MathErrors | list of 80x87 FPU errors, which result in an exception (when set to False no exception is raised, instead the result can be infinite or not a number)
MathInfinity | type of infinity used (depending on the FPU this is a reserved flag)
MathPrecision | precision used by the 80x87 FPU internally (see TPegtopMathPrecision)
Options | options used by TPegtopFormula
Parameters | parameter names
Valid | This is Valid, a member of class TPegtopFormula.
Methods
Method | Description
Compile | Compiles the current expression to machine code (only if it wasn't compiled yet).
Create | Creates a new TPegtopFormula component.
Destroy | Destroys a TPegtopFormula component.
Eval | Evaluates an expression with arguments set with SetArg. The expression is compiled automatically if it wasn't compiled yet.
GetArg | Get the current argument value given by its parameter index. This method usually is faster than the overloaded GetArg method accepting a parameter name.
Recompile | Forces the expression to be recompiled, even if it was compiled before.
SetArg | Set the an argument value given by its parameter index. This method usually is faster than the overloaded SetArg method accepting a parameter name.


TPegtopFormula Class Methods

Contents | Index
TPegtopFormula Class Methods
TPegtopFormula Class | Legend
Methods
Method | Description
Compile | Compiles the current expression to machine code (only if it wasn't compiled yet).
Create | Creates a new TPegtopFormula component.
Destroy | Destroys a TPegtopFormula component.
Eval | Evaluates an expression with arguments set with SetArg. The expression is compiled automatically if it wasn't compiled yet.
GetArg | Get the current argument value given by its parameter index. This method usually is faster than the overloaded GetArg method accepting a parameter name.
Recompile | Forces the expression to be recompiled, even if it was compiled before.
SetArg | Set the an argument value given by its parameter index. This method usually is faster than the overloaded SetArg method accepting a parameter name.


TPegtopFormula Class Properties

Contents | Index
TPegtopFormula Class Properties
TPegtopFormula Class | Legend
Properties
Property | Description
CodeLines | This is CodeLines, a member of class TPegtopFormula.
CodeSize | This is CodeSize, a member of class TPegtopFormula.
Expression | mathematical formula expression as a string (is compiled by calling Compile or automatically when needed)
MathErrors | list of 80x87 FPU errors, which result in an exception (when set to False no exception is raised, instead the result can be infinite or not a number)
MathInfinity | type of infinity used (depending on the FPU this is a reserved flag)
MathPrecision | precision used by the 80x87 FPU internally (see TPegtopMathPrecision)
Options | options used by TPegtopFormula
Parameters | parameter names
Valid | This is Valid, a member of class TPegtopFormula.


Legend

Contents | Index
Legend
TPegtopFormulaCompiler Class
Legend
Method
virtual


TPegtopFormulaCompiler Class Members

Contents | Index
TPegtopFormulaCompiler Class Members
TPegtopFormulaCompiler Class | Legend
Members
Methods
Method | Description
CleanUp | This is CleanUp, a member of class TPegtopFormulaCompiler.
Create | TPegtopFormulaCompiler
Destroy | This is Destroy, a member of class TPegtopFormulaCompiler.
Parse | This is Parse, a member of class TPegtopFormulaCompiler.


Members

Contents | Index
Legend
Method
virtual


TPegtopFormulaCompiler Class Methods

Contents | Index
TPegtopFormulaCompiler Class Methods
TPegtopFormulaCompiler Class | Legend
Methods
Method | Description
CleanUp | This is CleanUp, a member of class TPegtopFormulaCompiler.
Create | TPegtopFormulaCompiler
Destroy | This is Destroy, a member of class TPegtopFormulaCompiler.
Parse | This is Parse, a member of class TPegtopFormulaCompiler.


Legend

Contents | Index
Legend
TPegtopFormulaElement Class
Legend
Property
read only
Method
abstract
protected


TPegtopFormulaElement Class Members

Contents | Index
TPegtopFormulaElement Class Members
TPegtopFormulaElement Class | Legend
Members
Properties
Property | Description
Level | This is Level, a member of class TPegtopFormulaElement.
Negative | This is Negative, a member of class TPegtopFormulaElement.
Prev | This is Prev, a member of class TPegtopFormulaElement.
Prio | This is Prio, a member of class TPegtopFormulaElement.
Methods
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaElement.
GetPrio | This is GetPrio, a member of class TPegtopFormulaElement.


Members

Contents | Index
Legend
Property
read only
Method
abstract
protected


TPegtopFormulaElement Class Methods

Contents | Index
TPegtopFormulaElement Class Methods
TPegtopFormulaElement Class | Legend
Methods
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaElement.
GetPrio | This is GetPrio, a member of class TPegtopFormulaElement.


Methods

Contents | Index
Legend
Method
abstract
protected


TPegtopFormulaElement Class Properties

Contents | Index
TPegtopFormulaElement Class Properties
TPegtopFormulaElement Class | Legend
Properties
Property | Description
Level | This is Level, a member of class TPegtopFormulaElement.
Negative | This is Negative, a member of class TPegtopFormulaElement.
Prev | This is Prev, a member of class TPegtopFormulaElement.
Prio | This is Prio, a member of class TPegtopFormulaElement.


Legend

Contents | Index
Legend
TPegtopFormulaFunction Class
Legend
Method
virtual
protected
abstract
Property
read only


TPegtopFormulaFunction Class Members

Contents | Index
TPegtopFormulaFunction Class Members
TPegtopFormulaFunction Class | Legend
Members
Methods
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaFunction.
Create | TPegtopFormulaFunction
GetPrio | This is GetPrio, a member of class TPegtopFormulaFunction.
TPegtopFormulaElement Class
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaElement.
GetPrio | This is GetPrio, a member of class TPegtopFormulaElement.
Properties
TPegtopFormulaElement Class
Property | Description
Level | This is Level, a member of class TPegtopFormulaElement.
Negative | This is Negative, a member of class TPegtopFormulaElement.
Prev | This is Prev, a member of class TPegtopFormulaElement.
Prio | This is Prio, a member of class TPegtopFormulaElement.


Members

Contents | Index
Legend
Method
virtual
protected
abstract
Property
read only


TPegtopFormulaFunction Class Methods

Contents | Index
TPegtopFormulaFunction Class Methods
TPegtopFormulaFunction Class | Legend
Methods
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaFunction.
Create | TPegtopFormulaFunction
GetPrio | This is GetPrio, a member of class TPegtopFormulaFunction.
TPegtopFormulaElement Class
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaElement.
GetPrio | This is GetPrio, a member of class TPegtopFormulaElement.


Methods

Contents | Index
Legend
Method
virtual
protected
abstract


TPegtopFormulaFunction Class Properties

Contents | Index
TPegtopFormulaFunction Class Properties
TPegtopFormulaFunction Class | Legend
Properties
TPegtopFormulaElement Class
Property | Description
Level | This is Level, a member of class TPegtopFormulaElement.
Negative | This is Negative, a member of class TPegtopFormulaElement.
Prev | This is Prev, a member of class TPegtopFormulaElement.
Prio | This is Prio, a member of class TPegtopFormulaElement.


Legend

Contents | Index
Legend
TPegtopFormulaVariable Class
Legend
Property
read only
Method
virtual
protected
abstract


TPegtopFormulaVariable Class Members

Contents | Index
TPegtopFormulaVariable Class Members
TPegtopFormulaVariable Class | Legend
Members
Properties
Property | Description
DataAdr | This is DataAdr, a member of class TPegtopFormulaVariable.
TPegtopFormulaElement Class
Property | Description
Level | This is Level, a member of class TPegtopFormulaElement.
Negative | This is Negative, a member of class TPegtopFormulaElement.
Prev | This is Prev, a member of class TPegtopFormulaElement.
Prio | This is Prio, a member of class TPegtopFormulaElement.
Methods
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaVariable.
Create | TPegtopFormulaVariable
GetPrio | This is GetPrio, a member of class TPegtopFormulaVariable.
TPegtopFormulaElement Class
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaElement.
GetPrio | This is GetPrio, a member of class TPegtopFormulaElement.


Members

Contents | Index
Legend
Property
read only
Method
virtual
protected
abstract


TPegtopFormulaVariable Class Methods

Contents | Index
TPegtopFormulaVariable Class Methods
TPegtopFormulaVariable Class | Legend
Methods
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaVariable.
Create | TPegtopFormulaVariable
GetPrio | This is GetPrio, a member of class TPegtopFormulaVariable.
TPegtopFormulaElement Class
Method | Description
Compile | This is Compile, a member of class TPegtopFormulaElement.
GetPrio | This is GetPrio, a member of class TPegtopFormulaElement.


TPegtopFormulaVariable Class Properties

Contents | Index
TPegtopFormulaVariable Class Properties
TPegtopFormulaVariable Class | Legend
Properties
Property | Description
DataAdr | This is DataAdr, a member of class TPegtopFormulaVariable.
TPegtopFormulaElement Class
Property | Description
Level | This is Level, a member of class TPegtopFormulaElement.
Negative | This is Negative, a member of class TPegtopFormulaElement.
Prev | This is Prev, a member of class TPegtopFormulaElement.
Prio | This is Prio, a member of class TPegtopFormulaElement.


Legend

Contents | Index
Legend
TPegtopMacroAsmCode Class
Legend
Property
read only
Method
protected
virtual


TPegtopMacroAsmCode Class Members

Contents | Index
TPegtopMacroAsmCode Class Members
TPegtopMacroAsmCode Class | Legend
Members
Properties
TPegtopCompilerCode Class
Property | Description
Data | data block belonging to this code block
Lines | text lines of code block (for documentation, usually contains the asm instructions to generate the machine code)
TPegtopCompilerData Class
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)
Methods
TPegtopCompilerCode Class
Method | Description
AddAddr | Add virtual address to code block.
AddCode | Add code byte to code block.
AddJump | Add jump to code block. The target label can either be added before or after this operation.
AddLabel | Add label to code block.
AddLine | Add line of text to code block as documentation of the machine code (usually this is asm code).
AddrToHex | Transform virtual address to hex string.
CleanUp | Clean up name spaces after finishing code creation. This method makes sure all name spaces are closed, and should be called before destroying TPegtopCompilerCode. It is not part of the destructor, because a destructor should never raise exceptions.
Clear | Clear code block.
CloseNameSpace | Close name space opened with OpenNameSpace.
Create | Create new TPegtopCompilerCode object , reinitializing data type alignment (see TPegtopCompilerData constructor).
DecIndent | Decrease indent width used when adding text lines.
Destroy | Destroy TPegtopCompilerCode object. You should call CleanUp (see there) before destroying a TPegtopCompilerCode object.
IncIndent | Increase indent width used when adding text lines.
OpenNameSpace | Open new name space. Name spaces can be nested.
TPegtopCompilerData Class
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.


TPegtopMacroAsmCode Class Methods

Contents | Index
TPegtopMacroAsmCode Class Methods
TPegtopMacroAsmCode Class | Legend
Methods
TPegtopCompilerCode Class
Method | Description
AddAddr | Add virtual address to code block.
AddCode | Add code byte to code block.
AddJump | Add jump to code block. The target label can either be added before or after this operation.
AddLabel | Add label to code block.
AddLine | Add line of text to code block as documentation of the machine code (usually this is asm code).
AddrToHex | Transform virtual address to hex string.
CleanUp | Clean up name spaces after finishing code creation. This method makes sure all name spaces are closed, and should be called before destroying TPegtopCompilerCode. It is not part of the destructor, because a destructor should never raise exceptions.
Clear | Clear code block.
CloseNameSpace | Close name space opened with OpenNameSpace.
Create | Create new TPegtopCompilerCode object , reinitializing data type alignment (see TPegtopCompilerData constructor).
DecIndent | Decrease indent width used when adding text lines.
Destroy | Destroy TPegtopCompilerCode object. You should call CleanUp (see there) before destroying a TPegtopCompilerCode object.
IncIndent | Increase indent width used when adding text lines.
OpenNameSpace | Open new name space. Name spaces can be nested.
TPegtopCompilerData Class
Method | Description
AddByte | Add a byte value to the data block.
AddDouble | Add a double precision floating point value to the data block.
AddInt64 | Add a signed 64 bit integer value to the data block.
AddLongint | Add a signed 32 bit integer value to the data block.
AddSmallint | Add a signed 16 bit integer value to the data block.
AddWord | Add an unsigned 16 bit integer value to the data block.
Clear | Clear data block by setting its size to zero. The memory is not deallocated, and (large) data blocks are not truncated.
Create | Create new TPegtopCompilerData object, initializing data type alignment.
IncSize | Increase data block by x bytes, aligning to y bytes. If the memory allocated for the data block is too small, more memory is allocated.
SetByte | Set a specific byte within the data block to another value.


TPegtopMacroAsmCode Class Properties

Contents | Index
TPegtopMacroAsmCode Class Properties
TPegtopMacroAsmCode Class | Legend
Properties
TPegtopCompilerCode Class
Property | Description
Data | data block belonging to this code block
Lines | text lines of code block (for documentation, usually contains the asm instructions to generate the machine code)
TPegtopCompilerData Class
Property | Description
Ptr | pointer to virtual address within data block
Size | size of data block (not its capacity)


Legend

Contents | Index
Legend
TPegtopNamedAddress Class
Legend
Property
read only
Method


TPegtopNamedAddress Class Members

Contents | Index
TPegtopNamedAddress Class Members
TPegtopNamedAddress Class | Legend
Members
Properties
Property | Description
Address | This is Address, a member of class TPegtopNamedAddress.
Name | This is Name, a member of class TPegtopNamedAddress.
Methods
Method | Description
Create | Create new name TPegtopNamedAddress object.


TPegtopNamedAddress Class Methods

Contents | Index
TPegtopNamedAddress Class Methods
TPegtopNamedAddress Class | Legend
Methods
Method | Description
Create | Create new name TPegtopNamedAddress object.


TPegtopNamedAddress Class Properties

Contents | Index
TPegtopNamedAddress Class Properties
TPegtopNamedAddress Class | Legend
Properties
Property | Description
Address | This is Address, a member of class TPegtopNamedAddress.
Name | This is Name, a member of class TPegtopNamedAddress.


Legend

Contents | Index
Legend
TPegtopNamedAddressList Class
Legend
Method


TPegtopNamedAddressList Class Members

Contents | Index
TPegtopNamedAddressList Class Members
TPegtopNamedAddressList Class | Legend
Members
Methods
Method | Description
Find | Find TPegtopNamedAddress being part of this list by its name. If no item matches the name specified, nil is returned.


TPegtopNamedAddressList Class Methods

Contents | Index
TPegtopNamedAddressList Class Methods
TPegtopNamedAddressList Class | Legend
Methods
Method | Description
Find | Find TPegtopNamedAddress being part of this list by its name. If no item matches the name specified, nil is returned.


Legend

Contents | Index
Legend
TPegtopNameSpace Class
Legend
Property
read only
Method
virtual


TPegtopNameSpace Class Members

Contents | Index
TPegtopNameSpace Class Members
TPegtopNameSpace Class | Legend
Members
Properties
Property | Description
Name | This is Name, a member of class TPegtopNameSpace.
Methods
Method | Description
AddJump | Add jump to name space.
AddLabel | Add label to name space.
Create | Create new TPegtopNameSpace object.
Destroy | Destroy TPegtopNameSpace object.
LabelMissing | Return True if there are unresolved jumps (what means at least on label is missing).
ListJumps | Return list of jumps as a string.
ResolveJumps | Resolve all jumps to some label. Usually this method is called whenever a new label is added, to make sure all jumps defined before the label are adjusted.


TPegtopNameSpace Class Methods

Contents | Index
TPegtopNameSpace Class Methods
TPegtopNameSpace Class | Legend
Methods
Method | Description
AddJump | Add jump to name space.
AddLabel | Add label to name space.
Create | Create new TPegtopNameSpace object.
Destroy | Destroy TPegtopNameSpace object.
LabelMissing | Return True if there are unresolved jumps (what means at least on label is missing).
ListJumps | Return list of jumps as a string.
ResolveJumps | Resolve all jumps to some label. Usually this method is called whenever a new label is added, to make sure all jumps defined before the label are adjusted.


TPegtopNameSpace Class Properties

Contents | Index
TPegtopNameSpace Class Properties
TPegtopNameSpace Class | Legend
Properties
Property | Description
Name | This is Name, a member of class TPegtopNameSpace.


Contents

Contents | Index
Contents
Symbol Reference
Classes
EPegtopAsmInvalidOperand Class
EPegtopAsmInvalidOperand.CreateProp Constructor
EPegtopCompiler Class
EPegtopFormula Class
EPegtopFormulaArgument Class
EPegtopFormulaBadSpecifier Class
EPegtopFormulaBadSpecifier.Specifier Property
EPegtopFormulaBadSpecifier.CreateProp Constructor
EPegtopFormulaInvalid Class
EPegtopFormulaParameter Class
EPegtopFormulaParse Class
EPegtopFormulaParse.Expected Property
EPegtopFormulaParse.Expression Property
EPegtopFormulaParse.Invalid Property
EPegtopFormulaParse.Position Property
EPegtopFormulaParse.CreateProp Constructor
TPegtopAsmCode Class
TPegtopCompilerCode Class
TPegtopCompilerCode.Data Property
TPegtopCompilerCode.Lines Property
TPegtopCompilerCode.AddAddr Method
TPegtopCompilerCode.AddCode Method
TPegtopCompilerCode.AddJump Method
TPegtopCompilerCode.AddLabel Method
TPegtopCompilerCode.AddLine Method
TPegtopCompilerCode.AddrToHex Method
TPegtopCompilerCode.CleanUp Method
TPegtopCompilerCode.Clear Method
TPegtopCompilerCode.CloseNameSpace Method
TPegtopCompilerCode.Create Constructor
TPegtopCompilerCode.DecIndent Method
TPegtopCompilerCode.Destroy Destructor
TPegtopCompilerCode.IncIndent Method
TPegtopCompilerCode.OpenNameSpace Method
TPegtopCompilerData Class
TPegtopCompilerData.Ptr Property
TPegtopCompilerData.Size Property
TPegtopCompilerData.AddByte Method
TPegtopCompilerData.AddDouble Method
TPegtopCompilerData.AddInt64 Method
TPegtopCompilerData.AddLongint Method
TPegtopCompilerData.AddSmallint Method
TPegtopCompilerData.AddWord Method
TPegtopCompilerData.Clear Method
TPegtopCompilerData.Create Constructor
TPegtopCompilerData.IncSize Method
TPegtopCompilerData.SetByte Method
TPegtopFormula Class
TPegtopFormula.CodeLines Property
TPegtopFormula.CodeSize Property
TPegtopFormula.Expression Property
TPegtopFormula.MathErrors Property
TPegtopFormula.MathInfinity Property
TPegtopFormula.MathPrecision Property
TPegtopFormula.Options Property
TPegtopFormula.Parameters Property
TPegtopFormula.Valid Property
TPegtopFormula.Compile Method
TPegtopFormula.Create Constructor
TPegtopFormula.Destroy Destructor
Eval
TPegtopFormula.Eval Method ()
TPegtopFormula.Eval Method (array of Double)
GetArg
TPegtopFormula.GetArg Method (Integer)
TPegtopFormula.GetArg Method (String)
TPegtopFormula.Recompile Method
SetArg
TPegtopFormula.SetArg Method (Integer, Double)
TPegtopFormula.SetArg Method (String, Double)
TPegtopFormulaCompiler Class
TPegtopFormulaCompiler.CleanUp Method
TPegtopFormulaCompiler.Create Constructor
TPegtopFormulaCompiler.Destroy Destructor
TPegtopFormulaCompiler.Parse Method
TPegtopFormulaElement Class
TPegtopFormulaElement.Level Property
TPegtopFormulaElement.Negative Property
TPegtopFormulaElement.Prev Property
TPegtopFormulaElement.Prio Property
TPegtopFormulaElement.Compile Method
TPegtopFormulaElement.GetPrio Method
TPegtopFormulaFunction Class
TPegtopFormulaFunction.Compile Method
TPegtopFormulaFunction.Create Constructor
TPegtopFormulaFunction.GetPrio Method
TPegtopFormulaVariable Class
TPegtopFormulaVariable.DataAdr Property
TPegtopFormulaVariable.Compile Method
TPegtopFormulaVariable.Create Constructor
TPegtopFormulaVariable.GetPrio Method
TPegtopMacroAsmCode Class
TPegtopNamedAddress Class
TPegtopNamedAddress.Address Property
TPegtopNamedAddress.Name Property
TPegtopNamedAddress.Create Constructor
TPegtopNamedAddressList Class
TPegtopNamedAddressList.Find Method
TPegtopNameSpace Class
TPegtopNameSpace.Name Property
TPegtopNameSpace.AddJump Method
TPegtopNameSpace.AddLabel Method
TPegtopNameSpace.Create Constructor
TPegtopNameSpace.Destroy Destructor
TPegtopNameSpace.LabelMissing Method
TPegtopNameSpace.ListJumps Method
TPegtopNameSpace.ResolveJumps Method
Functions
IsInfinite Function
IsInfiniteOrNaN Function
IsNaN Function
IsNegInfinite Function
IsNegZero Function
IsPosInfinite Function
IsPosZero Function
IsZero Function
Structs, Records, Enums
TCharClass Enumeration
TPegtopCompilerDataType Enumeration
TPegtopFormulaOperator Enumeration
TPegtopFormulaOption Enumeration
TPegtopMathError Enumeration
TPegtopMathInfinity Enumeration
TPegtopMathPrecision Enumeration
TPegtopMathReg Enumeration
TPegtopMathRounding Enumeration
TPegtopProcReg Enumeration
TPegtopProcRegType Enumeration
Types
TOperatorPrecedence Type
TPegtopFormulaOptions Type
TPegtopMathErrors Type
TPegtopVirtualAddr Type
TPrecedence Type
Files
PegtopAssemblers.pas
PegtopCompilers.pas
PegtopFormulas.pas


Index

Contents | Index
Index
C | E | I | O | P | R | S | T
C
ccAlpha enumeration member
ccBraClose enumeration member
ccBraOpen enumeration member
ccDecSep enumeration member
ccDigit enumeration member
ccOperator enumeration member
ccSpace enumeration member
ccUnknown enumeration member
cdtByte enumeration member
cdtDouble enumeration member
cdtInt64 enumeration member
cdtLongint enumeration member
cdtSmallint enumeration member
cdtWord enumeration member
E
EPegtopAsmInvalidOperand
EPegtopAsmInvalidOperand class
CreateProp
EPegtopAsmInvalidOperand.CreateProp
EPegtopCompiler
EPegtopCompiler class
EPegtopFormula
EPegtopFormula class
EPegtopFormulaArgument
EPegtopFormulaArgument class
EPegtopFormulaBadSpecifier
EPegtopFormulaBadSpecifier class
CreateProp
Specifier
EPegtopFormulaBadSpecifier.CreateProp
EPegtopFormulaBadSpecifier.Specifier
EPegtopFormulaInvalid
EPegtopFormulaInvalid class
EPegtopFormulaParameter
EPegtopFormulaParameter class
EPegtopFormulaParse
EPegtopFormulaParse class
CreateProp
Expected
Expression
Invalid
Position
EPegtopFormulaParse.CreateProp
EPegtopFormulaParse.Expected
EPegtopFormulaParse.Expression
EPegtopFormulaParse.Invalid
EPegtopFormulaParse.Position
I
IsInfinite
IsInfinite function
IsInfiniteOrNaN
IsInfiniteOrNaN function
IsNaN
IsNaN function
IsNegInfinite
IsNegInfinite function
IsNegZero
IsNegZero function
IsPosInfinite
IsPosInfinite function
IsPosZero
IsPosZero function
IsZero
IsZero function
O
opAdd enumeration member
opDiv enumeration member
opMod enumeration member
opMul enumeration member
opNone enumeration member
opPow enumeration member
opSub enumeration member
P
PegtopAssemblers.pas
PegtopCompilers.pas
PegtopFormulas.pas
pfoAutoCloseBrackets enumeration member
pfoNationalDecimalSeparator enumeration member
pmeDenormal enumeration member
pmeDivByZero enumeration member
pmeInvalidOp enumeration member
pmeOverflow enumeration member
pmePrecision enumeration member
pmeUnderflow enumeration member
pmiAffine enumeration member
pmiProjective enumeration member
pmp24bit enumeration member
pmp53bit enumeration member
pmp64bit enumeration member
pmrDefault enumeration member
pmrDown enumeration member
pmrNearest enumeration member
pmrToZero enumeration member
pmrUp enumeration member
prt16bit enumeration member
prt32bit enumeration member
R
regAX enumeration member
regBP enumeration member
regBX enumeration member
regCX enumeration member
regDI enumeration member
regDX enumeration member
regEAX enumeration member
regEBP enumeration member
regEBX enumeration member
regECX enumeration member
regEDI enumeration member
regEDX enumeration member
regESI enumeration member
regESP enumeration member
regSI enumeration member
regSP enumeration member
S
st0 enumeration member
st1 enumeration member
st2 enumeration member
st3 enumeration member
st4 enumeration member
st5 enumeration member
st6 enumeration member
st7 enumeration member
T
TCharClass
TCharClass enumeration
TOperatorPrecedence
TOperatorPrecedence type
TPegtopAsmCode
TPegtopAsmCode class
TPegtopCompilerCode
TPegtopCompilerCode class
AddAddr
AddCode
AddJump
AddLabel
AddLine
AddrToHex
CleanUp
Clear
CloseNameSpace
Create
Data
DecIndent
Destroy
IncIndent
Lines
OpenNameSpace
TPegtopCompilerCode.AddAddr
TPegtopCompilerCode.AddCode
TPegtopCompilerCode.AddJump
TPegtopCompilerCode.AddLabel
TPegtopCompilerCode.AddLine
TPegtopCompilerCode.AddrToHex
TPegtopCompilerCode.CleanUp
TPegtopCompilerCode.Clear
TPegtopCompilerCode.CloseNameSpace
TPegtopCompilerCode.Create
TPegtopCompilerCode.Data
TPegtopCompilerCode.DecIndent
TPegtopCompilerCode.Destroy
TPegtopCompilerCode.IncIndent
TPegtopCompilerCode.Lines
TPegtopCompilerCode.OpenNameSpace
TPegtopCompilerData
TPegtopCompilerData class
AddByte
AddDouble
AddInt64
AddLongint
AddSmallint
AddWord
Clear
Create
IncSize
Ptr
SetByte
Size
TPegtopCompilerData.AddByte
TPegtopCompilerData.AddDouble
TPegtopCompilerData.AddInt64
TPegtopCompilerData.AddLongint
TPegtopCompilerData.AddSmallint
TPegtopCompilerData.AddWord
TPegtopCompilerData.Clear
TPegtopCompilerData.Create
TPegtopCompilerData.IncSize
TPegtopCompilerData.Ptr
TPegtopCompilerData.SetByte
TPegtopCompilerData.Size
TPegtopCompilerDataType
TPegtopCompilerDataType enumeration
TPegtopFormula
TPegtopFormula class
CodeLines
CodeSize
Compile
Create
Destroy
Eval
Eval
Expression
GetArg
GetArg
MathErrors
MathInfinity
MathPrecision
Options
Parameters
Recompile
SetArg
SetArg
Valid
TPegtopFormula.CodeLines
TPegtopFormula.CodeSize
TPegtopFormula.Compile
TPegtopFormula.Create
TPegtopFormula.Destroy
TPegtopFormula.Eval
TPegtopFormula.Expression
TPegtopFormula.GetArg
TPegtopFormula.MathErrors
TPegtopFormula.MathInfinity
TPegtopFormula.MathPrecision
TPegtopFormula.Options
TPegtopFormula.Parameters
TPegtopFormula.Recompile
TPegtopFormula.SetArg
TPegtopFormula.Valid
TPegtopFormulaCompiler
TPegtopFormulaCompiler class
CleanUp
Create
Destroy
Parse
TPegtopFormulaCompiler.CleanUp
TPegtopFormulaCompiler.Create
TPegtopFormulaCompiler.Destroy
TPegtopFormulaCompiler.Parse
TPegtopFormulaElement
TPegtopFormulaElement class
Compile
GetPrio
Level
Negative
Prev
Prio
TPegtopFormulaElement.Compile
TPegtopFormulaElement.GetPrio
TPegtopFormulaElement.Level
TPegtopFormulaElement.Negative
TPegtopFormulaElement.Prev
TPegtopFormulaElement.Prio
TPegtopFormulaFunction
TPegtopFormulaFunction class
Compile
Create
GetPrio
TPegtopFormulaFunction.Compile
TPegtopFormulaFunction.Create
TPegtopFormulaFunction.GetPrio
TPegtopFormulaOperator
TPegtopFormulaOperator enumeration
TPegtopFormulaOption
TPegtopFormulaOption enumeration
TPegtopFormulaOptions
TPegtopFormulaOptions type
TPegtopFormulaVariable
TPegtopFormulaVariable class
Compile
Create
DataAdr
GetPrio
TPegtopFormulaVariable.Compile
TPegtopFormulaVariable.Create
TPegtopFormulaVariable.DataAdr
TPegtopFormulaVariable.GetPrio
TPegtopMacroAsmCode
TPegtopMacroAsmCode class
TPegtopMathError
TPegtopMathError enumeration
TPegtopMathErrors
TPegtopMathErrors type
TPegtopMathInfinity
TPegtopMathInfinity enumeration
TPegtopMathPrecision
TPegtopMathPrecision enumeration
TPegtopMathReg
TPegtopMathReg enumeration
TPegtopMathRounding
TPegtopMathRounding enumeration
TPegtopNamedAddress
TPegtopNamedAddress class
Address
Create
Name
TPegtopNamedAddress.Address
TPegtopNamedAddress.Create
TPegtopNamedAddress.Name
TPegtopNamedAddressList
TPegtopNamedAddressList class
Find
TPegtopNamedAddressList.Find
TPegtopNameSpace
TPegtopNameSpace class
AddJump
AddLabel
Create
Destroy
LabelMissing
ListJumps
Name
ResolveJumps
TPegtopNameSpace.AddJump
TPegtopNameSpace.AddLabel
TPegtopNameSpace.Create
TPegtopNameSpace.Destroy
TPegtopNameSpace.LabelMissing
TPegtopNameSpace.ListJumps
TPegtopNameSpace.Name
TPegtopNameSpace.ResolveJumps
TPegtopProcReg
TPegtopProcReg enumeration
TPegtopProcRegType
TPegtopProcRegType enumeration
TPegtopVirtualAddr
TPegtopVirtualAddr type
TPrecedence
TPrecedence type


Welcome